Bug 143903 - CRASH: pasting transposed
Summary: CRASH: pasting transposed
Status: RESOLVED DUPLICATE of bug 144022
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.0.0 alpha1+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression, wantBacktrace
Depends on:
Blocks:
 
Reported: 2021-08-16 16:32 UTC by elias estatistics
Modified: 2021-08-30 15:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["ScColumn::SetPattern(long,ScPatternAttr%20const%20&)"]


Attachments
a) tables in calc b) Tables in writer to transfer them into calc (39.28 KB, application/zip)
2021-08-16 16:32 UTC, elias estatistics
Details
simplify reproducer (17.09 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-08-20 08:23 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description elias estatistics 2021-08-16 16:32:01 UTC
Created attachment 174324 [details]
a) tables in calc b) Tables in writer to transfer them into calc

Copying table from writer to calc and then transport it, results crash without log


a) copy any table from writer (preferably the last one) 
b) Paste it next to the end table that exist in Calc (in attachment)
c) Then cut it, and paste it either as tranpose
- by right-click menu single entry or
- by right-click tranpose menu entries (select values).


In both cases, I am unable to traspose this table. Libre office crash with no report / log. 

Libre office dev 7.3.0.0.alpha in ubuntu 20.3. 



A zip file with two attachments:
a) tables in writer to be transport into calc
b) Calc with some tables transported from writer.

(please, do this experiment many times. Sometimes dont crash, sometimes it does. In some tables always!) - this beviour existed to me in previous editions too.
Comment 1 Timur 2021-08-17 12:18:28 UTC
When attaching file please no zip but single files. 
Do you have "Experimental features" on, did you try without? 
In bugs like this, bug form asks if you tried to reset/delete user profile?
Comment 2 elias estatistics 2021-08-17 15:01:29 UTC
1) I had to attach two files, and here only one file i was allowed to attach. Therefore, i zipped them.

2) No, experimental features are not on.

3) No, I didnt rest my profile in libre and I dont want to.

4) Did you tried to make the steps that I described? did you find this bug or not?
Comment 3 Henrik Palomäki 2021-08-20 07:29:13 UTC
> Copying table from writer to calc and then transport it, results crash
> without log
I guess you meant "transpose" instead of "transport"?

Crash confirmed.
The bug was reproduced on 7.3.0.0.alpha0+ (x64).

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 23f17b7ea6fbd2f422c7e40192ae60e4df25224c
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: CL
Comment 4 Xisco Faulí 2021-08-20 07:57:29 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2021-08-20 08:23:46 UTC
Created attachment 174441 [details]
simplify reproducer

Steps to reproduce:
1. Open attached document
2. Cut BX18:CI30
3. Go to CI4
4. Paste as transposted

-> Crash
Comment 6 Xisco Faulí 2021-08-20 08:25:51 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c82d96da1c9a03e1742f2f5a7a93b9993c96a0a0

author	scito <info@scito.ch>	2021-05-31 22:26:21 +0200
committer	Eike Rathke <erack@redhat.com>	2021-06-04 12:21:29 +0200
commit	c82d96da1c9a03e1742f2f5a7a93b9993c96a0a0 (patch)
tree	101a55452e879a5ef7d61498be0e37deae2aadee
parent	940dad058c199c6b6990ad313db5a17758a19c65 (diff)
tdf#68976 fix paste transposed regression for notes/patterns

Bisected with: bibisect-linux64-7.2

Adding Cc: to scito
Comment 7 Roland Kurmann 2021-08-20 09:44:05 UTC
Thanks for adding me.

I can reproduce the bug. I'll try to fix in the next days.

Stacktrace from VSCode:

libsclo.so!ScColContainer::operator[](ScColContainer * this, const size_t nIndex) (libreoffice/sc/inc/colcontainer.hxx:43)
libsclo.so!ScTable::SetPattern(ScTable * this, SCCOL nCol, SCROW nRow, const ScPatternAttr & rAttr) (libreoffice/sc/source/core/data/table2.cxx:3061)
libsclo.so!lcl_SetTransposedPatternInRows(ScTable * pTransClip, SCROW nAttrRow1, SCROW nAttrRow2, SCCOL nCol1, SCROW nRow1, SCROW nCombinedStartRow, SCCOL nCol, const ScPatternAttr & rPatternAttr, bool bIncludeFiltered, const std::__debug::vector<int, std::allocator<int> > & rFilteredRows, SCROW nRowDestOffset) (libreoffice/sc/source/core/data/table2.cxx:1036)
libsclo.so!ScTable::TransposeColPatterns(ScTable * this, ScTable * pTransClip, SCCOL nCol1, SCCOL nCol, SCROW nRow1, SCROW nRow2, SCROW nCombinedStartRow, bool bIncludeFiltered, const std::__debug::vector<int, std::allocator<int> > & rFilteredRows, SCROW nRowDestOffset) (libreoffice/sc/source/core/data/table2.cxx:1061)
libsclo.so!ScTable::TransposeClip(ScTable * this, SCCOL nCol1, SCROW nRow1, SCCOL nCol2, SCROW nRow2, SCROW nCombinedStartRow, SCROW nRowDestOffset, ScTable * pTransClip, InsertDeleteFlags nFlags, bool bAsLink, bool bIncludeFiltered) (libreoffice/sc/source/core/data/table2.cxx:1002)
libsclo.so!ScDocument::TransposeClip(ScDocument * this, ScDocument * pTransClip, InsertDeleteFlags nFlags, bool bAsLink, bool bIncludeFiltered) (libreoffice/sc/source/core/data/document.cxx:2379)
libsclo.so!ScViewFunc::PasteFromClip(ScViewFunc * this, InsertDeleteFlags nFlags, ScDocument * pClipDoc, ScPasteFunc nFunction, bool bSkipEmpty, bool bTranspose, bool bAsLink, InsCellCmd eMoveMode, InsertDeleteFlags nUndoExtraFlags, bool bAllowDialogs) (libreoffice/sc/source/ui/view/viewfun3.cxx:951)
Comment 8 Xisco Faulí 2021-08-23 14:37:12 UTC
This issue got fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=23c1ec0d498124fbe275145d236db455f83cd850
Closing as RESOLVED DUPLICATED of bug 144022

*** This bug has been marked as a duplicate of bug 144022 ***