Bug 144139 - LO crashes when trying to print a form
Summary: LO crashes when trying to print a form
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.3.0 target:7.2.2 target:7.1.7
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2021-08-28 06:19 UTC by Robert Großkopf
Modified: 2021-09-30 10:55 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt with debug symbols (17.76 KB, text/plain)
2021-08-29 13:19 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2021-08-28 06:19:39 UTC
Test this bug with LO 7.1.0.3 or newer.

Open the attachment https://bugs.documentfoundation.org/attachment.cgi?id=91318 from bug 73139.
Open the form "Transactions_Currency_black".
Start File → Print.
Whole LO crashes immediately.
Starting LO in safe mode won't help here.

This bug won't appear in LO 7.0.5.2 on OpenSUSE 15.2 64 bit rpm Linux.
Comment 1 Mike Kaganski 2021-08-28 07:33:54 UTC
Can't repro using
Version: 7.2.0.4 (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 12; OS: Windows 10.0 Build 19043; UI render: default; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded

BUT: I possibly reproduce this (or maybe a different - hard to tell without OP posting the required Help->About info) problem using
Version: 7.2.0.4 (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 12; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded

In this case, the crash happens trying to open Print dialog *for the second time* (first time it opens OK; I just close it ant press toolbar button, or menu item, second time).

Of course, on this platform and using Skia, it might be completely different - but maybe OP uses gen with Skia?

Lubos: could you please take a look at least at this Skia-related problem on Windows?
Comment 2 Robert Großkopf 2021-08-28 08:07:34 UTC
Tested it a little bit more.
The bug doesn't appear when starting with 
SAL_USE_VCLPLUGIN=gen ./soffice

It will appear immediately when trying to open the print dialog with
Version: 7.2.0.4 / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 6; OS: Linux 5.3; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded

So it could be a special kf5 - bug.
Comment 3 Telesto 2021-08-28 17:45:59 UTC
Repro
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 05ff3d67d0e2e436406786c949eb7cfca107ba33
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

Print dialog does open.. but crashes after pressing cancel at the print dialog
Comment 4 Robert Großkopf 2021-08-28 19:03:02 UTC
(In reply to Telesto from comment #3)
> Repro
> Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
> Build ID: 05ff3d67d0e2e436406786c949eb7cfca107ba33
> CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
> Locale: nl-NL (nl_NL); UI: en-US
> Calc: CL
> 
> Print dialog does open.. but crashes after pressing cancel at the print
> dialog

So there is a difference in the behavior of win and kf5. Under Linux kf5 no dialog opens - the crash is directly after choosing Print in the menu.
Comment 5 Julien Nabet 2021-08-29 13:19:08 UTC
Created attachment 174605 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today + kf5 rendering, I had an assertion
Here are also some details from gdb:
(gdb) p cr
$1 = (cairo_t *) 0x2f4a360
(gdb) p *cr
$2 = <incomplete type>
(gdb) p source
$3 = (cairo_surface_t *) 0x88b2f50
(gdb) p *source
$4 = <incomplete type>
(gdb) p -rTR.mnSrcX
$5 = -1841
(gdb) p -rTR.mnSrcY
$6 = -859

I don't have this assertion with gen rendering.
Comment 6 Julien Nabet 2021-08-29 13:20:16 UTC
Michael: as usual, thought you might be interested in this one since it's specific to kf5.
Comment 7 Harshita Nag 2021-08-29 14:59:08 UTC
CONFIRMED on Ubuntu 18.04 LTS LibreOffice Version 7.1.1.2

Additonal Info:

Version: 7.1.1.2 / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: en-IN (en_IN); UI: en-US
Calc: threaded
Comment 8 Julien Nabet 2021-08-29 15:03:26 UTC
Harshita: you're right, I should have tested it with gtk3.
Comment 9 Julien Nabet 2021-08-29 15:29:43 UTC
Caolán: thought you might also be interested in this one since it concerns vcl.
Comment 10 Buovjaga 2021-08-29 19:30:04 UTC
Bibisected with linux-64-7.1 to
https://git.libreoffice.org/core/commit/40251f0e73d2cb700313395dcf49c43a9c1e8570
avoid intermediate bitmap causing blurring

Caolán is already in Cc.

Does not happen with gen.
Comment 11 Commit Notification 2021-09-28 14:42:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a0f6d3865dd113f38fd3aa673075e9fecd06f3cd

tdf#144139 don't crash when OutputDevice is a printer

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-09-28 19:49:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/36cec4b92e8be9f47467539967672ba8906096e1

tdf#144139 gen backend doesn't crash but DrawOutDev is a null op for Printers

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2021-09-29 08:54:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/8230731a4201419f32e80b22a576e8b2e1350277

Resolves: tdf#144139 checkboxs in print output shouldn't be themed

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2021-09-29 08:54:21 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/40268156401bf20f9ba9e66d4503a5242ec4502b

Resolves: tdf#144139 checkboxs in print output shouldn't be themed

It will be available in 7.1.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2021-09-29 08:57:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fbfd91f2c5f4d66570c2d5a6f048b21f5d1671a4

Resolves: tdf#144139 checkboxs in print output shouldn't be themed

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2021-09-29 10:22:36 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/39a6ea1fea4c0a624d19b4a5f0bcfd0e4cad0a20

tdf#144139 don't crash when OutputDevice is a printer

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2021-09-29 10:22:47 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7d21e2bc4628138bf2617a5c672c0da8d4e9e96f

Related: tdf#144139 use the classic size calculation

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Buovjaga 2021-09-29 15:10:44 UTC
Verified, thanks!

Arch Linux 64-bit
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 057a74c2f20256c34e97dae246e6e1867a364b84
CPU threads: 8; OS: Linux 5.14; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 29 September 2021
Comment 19 Commit Notification 2021-09-30 08:56:33 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2-2":

https://git.libreoffice.org/core/commit/95a2e765469ed072c35cf487b0526c93993ce1c4

Resolves: tdf#144139 checkboxs in print output shouldn't be themed

It will be available in 7.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2021-09-30 09:09:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/7b2021a01303ef9efad652ddedea20758ce1f719

Related: tdf#144139 use the classic size calculation

It will be available in 7.1.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2021-09-30 09:09:18 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/8082ff4ab592a63b3546f26b0e9a522fc7e4f8ba

Related: tdf#144139 use the classic size calculation

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Julien Nabet 2021-09-30 10:55:54 UTC
Simplify a bit targets.