Bug 144176 - Cannot see last line of inserted comment
Summary: Cannot see last line of inserted comment
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-30 10:02 UTC by Alex
Modified: 2022-01-17 07:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2021-08-30 10:02:14 UTC
Description:
When inserting a comment longer than a few lines, the last line cannot be seen. Instead, it is covered by the author and date information. You cannot scroll down to see it.

Steps to Reproduce:
1. New text document
2. Insert comment
3. Type until the text wraps to the next line.

Actual Results:
The cursor moves down to the next line, which is covered by the author and date information.

Expected Results:
The author and date information should not cover the last line of the comment.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 7.2.0.4 (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 1 [REDACTED] 2021-08-30 12:02:59 UTC
No repro

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: d350a1364a1c34b96d00f2f716c44882b7b57fe9
CPU threads: 1; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-US (en_DE); UI: de-DE
Calc: threaded

No repro

Version: 7.2.0.4 (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 1; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-US (en_DE); UI: en-US
Calc: threaded
Comment 2 Alex 2021-08-30 22:58:46 UTC
I have also tried completely uninstalling and reinstalling LibreOffice, but it did not help.

Even going into Tools -> Options -> User Data and deleting my first and last name had no effect. Instead of my name covering the last line of comment text, "Unknown Author" covers it.

This even happens in Safe Mode.

I am running the latest version of 64-bit Windows 10 on a Surface Pro 4, with the resolution set at 2736x1824.
Comment 3 Alistair Saywell 2021-09-02 10:39:49 UTC
Partial reproduce

Following from https://ask.libreoffice.org/t/last-line-of-comments-not-visible/67586, I get the bottom half of the last line of the comment hidden under author and date info in LO 7.2.0.4. The same document opened in LO 7.1.5.2 opens normally with comments fully visible. Turning off Skia makes no difference.

Version: 7.2.0.4 (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-NZ (en_NZ); UI: en-GB
Calc: CL
Comment 4 Tales Tomaz 2021-09-10 10:44:17 UTC
Partially reproduce

Bottom half of the last line of the comment hidden behind author and date info in LO 7.2.0.4.

Info:
Version: 7.2.0.4 / LibreOffice Community
Build ID: 20(Build:4)
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-GB (en_GB.UTF-8); UI: en-GB
7.2.0-2
Calc: threaded
Comment 5 Alex 2021-09-19 09:22:59 UTC
Issue persists in 7.2.1.2 (Windows 64-bit).

Version: 7.2.1.2 (x64) / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 6 Deep17 2021-09-29 14:26:41 UTC
This bug is still present in

Version: 7.2.1.2 (x64) / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 8; OS: Windows 10.0 Build 17763; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: a78190da867864485b5d0a91238616bd4090b5b5
CPU threads: 8; OS: Windows 10.0 Build 17763; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 7 Nikolay Dim 2022-01-16 13:31:18 UTC
This bug is resolved in

Version: 7.2.5.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.2.5~rc2-0ubuntu0.18.04.1~lo1
Calc: threaded
Comment 8 Buovjaga 2022-01-16 17:23:29 UTC
(In reply to Nikolay Dim from comment #7)
> This bug is resolved in
> 
> Version: 7.2.5.2 / LibreOffice Community
> Build ID: 20(Build:2)
> CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: gtk3
> Locale: en-US (en_US.UTF-8); UI: en-US
> Ubuntu package version: 1:7.2.5~rc2-0ubuntu0.18.04.1~lo1
> Calc: threaded

Does this mean that you saw the bug in an older version?

Alex and others: maybe you could test again with a newer version.
Comment 9 Alex 2022-01-17 06:23:53 UTC
(In reply to Buovjaga from comment #8)
> (In reply to Nikolay Dim from comment #7)
> > This bug is resolved in
> > 
> > Version: 7.2.5.2 / LibreOffice Community
> > Build ID: 20(Build:2)
> > CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: gtk3
> > Locale: en-US (en_US.UTF-8); UI: en-US
> > Ubuntu package version: 1:7.2.5~rc2-0ubuntu0.18.04.1~lo1
> > Calc: threaded
> 
> Does this mean that you saw the bug in an older version?
> 
> Alex and others: maybe you could test again with a newer version.

Tested with 7.2.5.2 (x64) and the problem seems to be resolved.
Comment 10 Buovjaga 2022-01-17 07:27:59 UTC
Great news, let's close