Bug 144462 - Impress' "Automatic" font color doesn't work in PowerPoint
Summary: Impress' "Automatic" font color doesn't work in PowerPoint
Status: RESOLVED DUPLICATE of bug 94122
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-13 06:56 UTC by skierpage
Modified: 2021-09-13 09:54 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description skierpage 2021-09-13 06:56:48 UTC
It seems by default Impress text uses Format > Character > Font effects > Font color: Automatic., which intelligently switches from black to white on a dark background. For example if you Insert > Media > Photo Album and choose "Add caption to each slide" then when you click to add a title in the semi-transparent dark bar, the text will be white.

However, if you save the resulting presentation as .pptx and then view it in Microsoft PowerPoint for Android, the text is always black (and thus illegible black on gray in photo captions).

I don't know if Microsoft PowerPoint supports automatic text color. Even if it doesn't, it's important that Impress try to do the right thing, or at least the documentation should mention the restriction.

FWIW the ODP XML <style:text-properties> attributes for Font color: Automatic might be
   style:use-window-font-color="true" loext:opacity="0%
Comment 1 Timur 2021-09-13 09:54:55 UTC
Seems duplicate. Please search before reporting.

*** This bug has been marked as a duplicate of bug 94122 ***