Bug 144631 - Inconsistent LibreOffice Base Query Design Run Sql Command Directly Toolbar Button Tick Colour across icon themes
Summary: Inconsistent LibreOffice Base Query Design Run Sql Command Directly Toolbar B...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.1.1 rc
Hardware: All All
: medium normal
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.3.0 target:7.2.3
Keywords:
Depends on:
Blocks: Icon-Theme-Colibre
  Show dependency treegraph
 
Reported: 2021-09-20 22:46 UTC by flywire
Modified: 2021-09-27 22:44 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Wrong LibreOffice Base Query Design Run Sql Command Directly Toolbar Button Tick Colour (14.21 KB, image/png)
2021-09-20 22:46 UTC, flywire
Details

Note You need to log in before you can comment on or make changes to this bug.
Description flywire 2021-09-20 22:46:58 UTC
Created attachment 175153 [details]
Wrong LibreOffice Base Query Design Run Sql Command Directly Toolbar Button Tick Colour

The Base Query Design Run Sql Command Directly Toolbar Button Tick Colour is consistently green except in the toolbar where a blue tick is used. The blue highlights used in this theme are inconsistent with usage elsewhere in the program and documentation.

Version: 7.2.0.3 (x64) / LibreOffice Community
Build ID: 2a7ea282da28d665a7dc086360567b4aea27bf08
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-AU (en_AU); UI: en-GB
Calc: threaded
Comment 2 Alex Thurgood 2021-09-21 08:36:17 UTC
No repro with

Version: 7.2.1.2 / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 8; OS: Mac OS X 11.5.2; UI render: default; VCL: osx
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Calc: threaded

using Karasa Jaga (SVG) icon theme. The icon has a green tick, even in the toolbar.


@flywire :
does this occur with a particular icon theme ?
is this particular to Windows ?
Comment 3 flywire 2021-09-21 10:20:43 UTC
Tools, Options, View, Icon Style: Automatic (Colibre) ie Win10 default.

For Run SQL Command Directly:
Breeze - no ticks
Colibre - *menu blue and toolbar green*
Elementary -  menu and toolbar blue. Why?
Karasa Jaga - menu and toolbar green
Sifr - NA (B&W)
Sukapura -  menu and toolbar green

SVG always appears the same and non SVG.
Comment 4 Alex Thurgood 2021-09-21 11:00:16 UTC
Confirming with

Version: 7.2.1.2 / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 8; OS: Mac OS X 11.5.2; UI render: default; VCL: osx
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Calc: threaded

No idea why there isn't consistency in the icon sets for this function.
Comment 5 flywire 2021-09-21 12:37:14 UTC
I picked this as a trivial example of poor UI. The fix requires no programming, just recolouring images.

Regardless, it's an issue for the icon theme designers. In our light documentation world, I doubt the subtleties of the messages in the icons have been passed on to the designers. I suppose they are a mix of base image with enhancements, some of which is colour although not in monochrome icon themes. This highlights the need for a technical review of the icon themes.

A few tweaks here and there would improve existing functionality but UI requires a consensus. I'd really like to work with others interested in improving the Base UI, and someone that can code it.
Comment 6 Alex Thurgood 2021-09-21 14:14:56 UTC
Changing component to UI
Comment 7 Julien Nabet 2021-09-21 19:25:57 UTC
Heiko/Xisco: thought you might be interested since it concerns UI part.

Robert: put you in cc since as Base testing expert, even if it's just an icon, you may have some opinion here.
Comment 8 Heiko Tietze 2021-09-22 09:56:20 UTC
(In reply to flywire from comment #0)
> The "Base Query Design Run Sql Command Directly Toolbar Button Tick Colour"...
*lol*

Rizal, Andreas: What do you think about the BQDRSCDTBT color?
Comment 9 Rizal Muttaqin 2021-09-23 04:40:16 UTC
(In reply to Heiko Tietze from comment #8)
> (In reply to flywire from comment #0)
> > The "Base Query Design Run Sql Command Directly Toolbar Button Tick Colour"...
> *lol*
> 
> Rizal, Andreas: What do you think about the BQDRSCDTBT color?

*absurd name, lol*
https://gerrit.libreoffice.org/c/core/+/122504
Comment 10 flywire 2021-09-23 04:44:50 UTC
Blue icons:
/icon-themes/colibre/cmd/lc_sbanativesql.png
/icon-themes/elementary/cmd/lc_sbanativesql.png
Comment 11 Rizal Muttaqin 2021-09-23 04:53:32 UTC
(In reply to flywire from comment #10)
> Blue icons:
> /icon-themes/colibre/cmd/lc_sbanativesql.png
> /icon-themes/elementary/cmd/lc_sbanativesql.png

Consistency should be achieved at the icon theme level, not between them. If you think the elementary icon theme needs to be changed as well, create a new different report and convince the designer to do so.
Comment 12 Commit Notification 2021-09-23 05:44:06 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0b810cc0f04241e644c82ba8bdad6a075b964118

tdf#144631 Colibre: sync up query/sql/report execution icons

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2021-09-23 06:56:03 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/03a215cfb95fea956b90d8068f4504e9671defe3

tdf#144631 Colibre: sync up query/sql/report execution icons

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 flywire 2021-09-27 22:03:27 UTC
(In reply to Commit Notification from comment #12)
> tdf#144631 Colibre: sync up query/sql/report execution icons

Fixed in Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 891dfac4bcb600cec2c860bde6d0c8607305102e
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-AU (en_AU); UI: en-GB
Calc: threaded