Bug 144772 - Basic Macro oEvent.Source execution in a form, started in a Text [VARCHAR] field
Summary: Basic Macro oEvent.Source execution in a form, started in a Text [VARCHAR] field
Status: RESOLVED DUPLICATE of bug 142415
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.1.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2021-09-28 15:05 UTC by bugReportLOm
Modified: 2021-10-31 23:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample odb file (13.19 KB, application/vnd.sun.xml.base)
2021-10-03 15:21 UTC, bugReportLOm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugReportLOm 2021-09-28 15:05:48 UTC
Description:
The following makro does not work any longer. 

Error message:
BASIC run time error
argument not optional

this line is marked:
oFeld = oEvent.Source

The makro is started by clicking in a form on a Text [VARCHAR] field containing a link. In the form Properties: Text box, events the makro is connected to "Mouse button pressed".

Robert Grosskopf provided this helpful Makro to directly open an internet link or LO file from a text field in a base form:

REM  *****  BASIC  *****

SUB Website_Aufruf(oEvent AS OBJECT)
	REM Aufruf einer Website oder des Mailprogramms mit einer vorgegebenen Mailadresse
	DIM oFeld AS OBJECT
	DIM oShell AS OBJECT
	DIM stFeld AS STRING
	oFeld = oEvent.Source
	REM Den Text aus der Dateiauswahl auslesen
	stFeld = oFeld.Text
	IF stFeld = "" THEN
		EXIT SUB
	END IF
	IF InStr(stFeld,"@") THEN
		stFeld = "mailto:"+stFeld
	ELSEIF InStr(stFeld,"http://") OR InStr(stFeld,"https://") THEN
		stFeld = convertToUrl(stFeld)	'convertToUrl erkennt, dass mit http:// bereits eine Verbindung vorgegeben ist. file:/// wird nicht gesetzt
	ELSE	
	END IF
	REM Start des Files mit der entsprechenden URL-Verbindung
	oShell = createUnoService("com.sun.star.system.SystemShellExecute")
	oShell.execute(stFeld,,0)
END SUB

HSQLDB odb, Java Version 8 Update 301

Problem in:
Version: 7.1.6.2 (x64) / LibreOffice Community
Build ID: 0e133318fcee89abacd6a7d077e292f1145735c3
CPU threads: 6; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

but not in: 
Version: 7.0.6.2 (x64)
Build ID: 144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b
CPU threads: 6; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

Actual Results:
makro does not start

Expected Results:
makro starts


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Error message:
BASIC run time error
argument not optional

this line is marked:
oFeld = oEvent.Source
Comment 1 Xisco Faulí 2021-09-29 15:32:13 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 bugReportLOm 2021-10-03 15:21:43 UTC
Created attachment 175479 [details]
sample odb file

text_field_bug_2021-10-01.odb

clicking in the form "data" on the field "link" opens in a browser the internet site.

works in Version: 7.0.6.2 (x64)

not in Version: 7.2.1.2 (x64)
Comment 3 Alex Thurgood 2021-10-11 08:59:28 UTC
Tested on

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 56883788d0090383dad58552f5a11044ffe64a44
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: fr-FR (fr_FR.UTF-8); UI: en-US
Calc: threaded

No repro on macOS daily master build.
If I Cmd-click on the link (which is the default for link opening on macOS) in the link field, the link gets loaded and opened in my default browser.
Comment 4 Alex Thurgood 2021-10-11 09:15:37 UTC
Reproduced in LO7162 on macOS 

Version: 7.1.6.2 / LibreOffice Community
Build ID: 0e133318fcee89abacd6a7d077e292f1145735c3
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Calc: threaded

Also reproduced on macOS in

Version: 7.2.1.2 / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Calc: threaded

If there is a fix that has gone into 7.3alpha, we should get it backported to 7.2.x.
Comment 5 Aron Budea 2021-10-31 23:10:26 UTC
Reverse-bibisected the fixing commit, determining it to be a dupe of bug 142415.

*** This bug has been marked as a duplicate of bug 142415 ***