Bug 144908 - Calc crashes when trying to pickup table from odb as datasource
Summary: Calc crashes when trying to pickup table from odb as datasource
Status: RESOLVED DUPLICATE of bug 144564
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-04 09:38 UTC by herman.viaene
Modified: 2021-10-04 09:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description herman.viaene 2021-10-04 09:38:44 UTC
Description:
LO 7.1.6 on Windows 10
I created - for some other purpose - a very simple odb with just one table, and had it registered in LO.
Now I want to see this table as a datasource in Calc, so I open a new spreadsheet, View - Datasources and the odb appeas as one of the registered databases. When I expand the table item, I first get the small wheel, and then Calc commletely crashes.
This has worked well in LO 7.0.4 at least, I discovered the problem in 7.1.5, upgraded to 7.1.6 with the same problem.
I amwilling to upload the odb.

Steps to Reproduce:
1.Create a new odb, register it
2.Create a table in it with 3 fields: one integer autofill, two varchar(100) labeled name and emailadres
3.Populate the table with 3 rows
4.Close and save the odb, open a new calc spreadsheet and try to use the table from the odb as datasource.

Actual Results:
Calc crashes

Expected Results:
Crash
Displayed the rows of the datasource table


Reproducible: Always


User Profile Reset: No



Additional Info:
Crash report at https://crashreport.libreoffice.org/stats/crash_details/d4458e3b-a49f-4bc1-892f-ac633d968417
Version: 7.1.6.2 (x64) / LibreOffice Community
Build ID: 0e133318fcee89abacd6a7d077e292f1145735c3
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: nl-BE (nl_BE); UI: nl-NL
Calc: threaded
Comment 1 Xisco Faulí 2021-10-04 09:45:48 UTC
Thanks for reporting this issue. It looks like a duplicate of bug 144564.
The issue should be fixed in LibreOffice 7.2.2 due to be released next week

*** This bug has been marked as a duplicate of bug 144564 ***