Bug 145072 - wrong page count after title page
Summary: wrong page count after title page
Status: RESOLVED DUPLICATE of bug 117231
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Fields-Dialog
  Show dependency treegraph
 
Reported: 2021-10-11 12:40 UTC by kubbugrep
Modified: 2021-11-10 08:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
document with 6 pages being wrongly numbered as described (5.82 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-10-11 12:40 UTC, kubbugrep
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kubbugrep 2021-10-11 12:40:44 UTC
Created attachment 175666 [details]
document with 6 pages being wrongly numbered as described

After formatting the first page of a document (with lets say 6 pages) as title page (Format -> Title page) including the "Page numbering" option "Reset page numbering after title pages" with "Page number" set to "1" the shown page number is increased by 1, even though the actual number of pages is unchanged.  As expected there is no page number shown on the first page, but the remaining 5 pages will now get numbered as "1 of 7" to "5 of 7".

I would assume a simple sign error in the code, since the shown number of pages is expected to decrease by 1, with the remaining pages being numbered as "1 of 5" to "5 of 5".
Comment 1 kubbugrep 2021-10-11 12:41:31 UTC
Version: 7.2.2.2 (x64) / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL
Comment 2 Dieter 2021-10-29 08:25:21 UTC
Attached document has two fields on each page from page two on
a) Page Number => it starts with 1 on second page, because first page is title page (expected)
b) Page Count => it shows the total number of pages and therefor includes title page (exected)

Si I would say, that there is no bug but perhaps there should be an option to adjust page count in the fields dialog (tab document -> type "statistics")

cc: Design Team for further input and decision

Perhaps a duplicate of bug 71583
Comment 3 kubbugrep 2021-10-29 09:46:41 UTC
Your comment a) is absolutely correct and I would also agree, that the best would be an option whether to include non-numbered title pages(s) in the total page count.

But your comment b) is not correct, since there are only 6 pages in total. Therefore according to your comment a) the total number of pages must not exceed 6, without the unnumbered title page even 5, but never 7.
Comment 4 Dieter 2021-10-29 09:59:10 UTC
(In reply to kubbugrep from comment #3)
> But your comment b) is not correct, since there are only 6 pages in total.
> Therefore according to your comment a) the total number of pages must not
> exceed 6, without the unnumbered title page even 5, but never 7.

That's the old problem, that LO inserts (invisible) blank page (see bug 117231)
Comment 5 kubbugrep 2021-11-04 06:23:54 UTC
(In reply to Dieter from comment #4)
> That's the old problem, that LO inserts (invisible) blank page (see bug
> 117231)

The problem discussed there seems to be slightly different, though perhaps not completely unrelated.
Comment 6 Heiko Tietze 2021-11-10 08:42:24 UTC
If you print, the preview shows the actual situation with no number on the title page, followed by a blank page, and then five pages with text. The total number is 7 => NAB.

But let's discuss it on the other bug.

*** This bug has been marked as a duplicate of bug 117231 ***