Bug 145101 - FILESAVE XLS Calc header right hand field truncates contents either on FILESAVE & exiting Calc or on next FILEOPEN of that spreadsheet file. Depends on formatted text in middle field
Summary: FILESAVE XLS Calc header right hand field truncates contents either on FILESA...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: All All
: medium major
Assignee: Not Assigned
Keywords: dataLoss, filter:xls
Depends on:
Blocks: XLS Calc-Header-Footer
  Show dependency treegraph
Reported: 2021-10-12 19:54 UTC by engineermikef
Modified: 2022-11-01 13:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

Calc spreadsheet file showing bug in saved Header right hand field (21.00 KB, application/vnd.ms-excel)
2021-10-12 19:56 UTC, engineermikef
Example ODS file (9.36 KB, application/vnd.oasis.opendocument.spreadsheet)
2022-11-01 13:47 UTC, Buovjaga

Note You need to log in before you can comment on or make changes to this bug.
Description engineermikef 2021-10-12 19:54:16 UTC
Header contents on Calc spreadsheets get truncated (chops off some amount of the right hand Header field contents) when saving the file and either when exiting Calc or when reopening the file (either on FILEOPEN OR FILESAVE).  This has been a problem in various builds of LibreOffice over the years and seemed fixed in 7.0.5.  I just upgraded to: (x64) build 87b77fad49947c1441b67c559c339af8f3517e22 Windows 10.0 Build 19043, and the bug is back.

Steps to Reproduce:
1.insert header contents in right hand field (name, address, phone, email)
2.save file & exit Calc
3.reopen Calc & load file, go to Print Preview & right hand Header contents is missing last 13 characters.
4. Appears to happen on either exiting the file (and leaving LibreOffice active) or when exiting Calc & LibreOffice.
5. I tried reducing # of characters in the right Header field by 5 characters, and that reduced the concatenation of the contents when exiting/reopening the file by 3 characters, so it is not a max# of characters problem
6. Once I repair the right Header field contents, it remains correct as long as the spreadsheet file is open (i.e. this is not a FILESAVE problem, it appears to do with either exiting or opening the file)
7. I tried opening other files and some retain right Header field contents properly, some get concatenated worse and some less bad.
8. There is no Enable OpenGL in this LibreOffice build, only SKIA
9. In the spreadsheet file attached herewith the Header had 10 digit phone# and 23 character email address below snail mail address

Actual Results:
Same bug, contents of right Header are truncated.  However, once truncated, if I do not repair the field contents, save, exit, then reopen Calc & load the file, the truncation does not get worse.  In previous LibreOffice versions I experienced random further erosions of that field if the file was not opened for many months then was opened- field would be further truncated (I have not had for long so I can't test this)

Expected Results:
Always retain the Header contents unless deliberately edited.

Reproducible: Always

User Profile Reset: No

Additional Info: (x64) / LibreOffice Community
Build: 87b77fad49947c1441b67c559c339af8f3517e22 
Environment: CPU Threads: 4; OS: Windows 10.0 Build 19043
User Interface: UI render: SKIA/Raster; VCL:Win
Locale: en-US (en_US); UI: en-US
Misc: CALC:threaded
Comment 1 engineermikef 2021-10-12 19:56:33 UTC
Created attachment 175699 [details]
Calc spreadsheet file showing bug in saved Header right hand field
Comment 2 Buovjaga 2022-11-01 13:47:25 UTC
Created attachment 183359 [details]
Example ODS file

I reproduce already with LibreOffice 3.3.0. Also with 7.0. So there does not seem to have been a regression related to this.

It seems to be related to the text formatting in the middle field. If it contains plain text, the data is not lost from the right field. It is not necessary to have the date field in the left field.

There is a backwards incompatibility with files saved with the latest version vs. older versions. So when testing with other versions, I had to create another file with LibreOffice 7.0.

The attached ODS file is saved with 7.5 and older versions don't show any header.

Arch Linux 64-bit
Version: (X86_64) / LibreOffice Community
Build ID: 85a5233275ab83fe0d6b943b298695387d97accd
CPU threads: 8; OS: Linux 6.0; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 1 November 2022