Bug 145135 - Provide documentation about difference between moving anchor and moving image
Summary: Provide documentation about difference between moving anchor and moving image
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Ross Johnson
URL:
Whiteboard: target:7.3.0
Keywords:
Depends on:
Blocks: Anchor-and-Text-Wrap Help-Changes-Features
  Show dependency treegraph
 
Reported: 2021-10-14 15:24 UTC by Dieter
Modified: 2021-10-30 07:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dieter 2021-10-14 15:24:17 UTC
This is a followup of bug 144611

There's a difference between moving the anchor of an image (anchor to paragraph) and moving the image itself: If you move the anchor from one paragraph to another paragraph, LO keeps the distance between anchor and image (so anchor and image move). If you drag the image, you can reduce or expand the distance between anchor and image (since only the image moves)

This should be added to documentation, for example to documentation about opositioning objects: https://help.libreoffice.org/7.3/en-GB/text/swriter/guide/anchor_object.html?&DbPAR=WRITER&System=WIN

Haven't tested for other objects than images
Comment 1 Ross Johnson 2021-10-15 06:11:58 UTC
The LO 7.2 Writer Guidebook section on positioning images begins with the following preamble:

----
When you add an image to a text document, you need to choose how to position
it with respect to the text and other images. Positioning is controlled by
four settings:
    • Arrangement refers to the placement of an image on an imaginary vertical
      axis. Arrangement controls how images are stacked upon each other or
      relative to the text.
    • Alignment refers to the vertical or horizontal placement of an image in
      relation to the chosen anchor point.
    • Anchoring refers to the reference point for the images. This point could
      be the page or frame where the object is, a paragraph, or even a
      character. An image always has an anchor point.
    • Text wrapping refers to the relation of images to the surrounding text,
      which may wrap around the image on one or both sides, be overprinted
      behind or in front of the image, or treat the image as a separate
      paragraph or character.
----

This is the preamble to more detailed sub sections in the guide, while the text on the Help page reads:

"You can use anchors to position an object, graphic, or frame in a document. An anchored item remains in place, or moves when you modify the document. The following anchoring options are available"


I propose that this text be supplemented by the text from the guidebook, for example:

"An anchor is the reference point for an object, such as an image. This point could be the page or frame where the object is, a paragraph, or even a character. An image always has an anchor point.

An anchor can move along with its referenced element (page, paragraph etc) when you modify the document. The object retains it's logical position relative to it's anchor so that whenever the referenced element moves the object moves relative to it.

The following anchoring options are available:"


There is also the following text on the Help page that is actually relevant to this issue:

"When you insert an object, graphic or frame, an anchor icon appears where the item is anchored. You can position an anchored item by dragging the item to another location. To change the anchoring options of an item, right-click the item, and then choose an option from the Anchor sub-menu."

I would propose changing the second sentence of that paragraph to something like:

"You can move an anchor or, keeping other object constraints in mind, position an object relative to it's anchor by dragging the object."


There isn't just one simple rule:

1) No anchor symbol appears if the object is anchored "as a character". The most reliable way to move this object is to cut then paste it to the new location. Moving the object itself can result in very unexpected outcomes, possibly due to bugs.

This is, almost without exception, the anchor type used in the Guidebook itself.

2)  For the "to ..." anchor options, dragging the object can give unexpected results depending on other settings for the object, such as wrap or alignment. Dragging the object also has limits depending on the reference element. Move it too far and the anchor point will snap to a new reference element of the same type, eg, the next paragraph. It is more reliable for larger moves to drag the anchor point itself or choose a more appropriate reference element, then drag the object for smaller adjustments.

3) The description for anchor "to character" is deceptive or confusing unless you've read the Guidebook. It actually anchors the object TO THE PARAGRAPH that contains the character. This would be used, for example, if the object must stay with the paragraph that contains a specific symbol, word or phrase. The Help page text for this option needs to be expanded to include the reference to "paragraph". This option could be more appropriately named "to paragraph containing character".
Comment 2 Dieter 2021-10-15 08:35:29 UTC
(In reply to Ross Johnson from comment #1)
> I propose that this text be supplemented by the text from the guidebook, for
> example:
> 
> "An anchor is the reference point for an object, such as an image. This
> point could be the page or frame where the object is, a paragraph, or even a
> character. An image always has an anchor point.
> 
> An anchor can move along with its referenced element (page, paragraph etc)
> when you modify the document. The object retains it's logical position
> relative to it's anchor so that whenever the referenced element moves the
> object moves relative to it.
> 
> The following anchoring options are available:"

+1 from my side

> I would propose changing the second sentence of that paragraph to something
> like:
> 
> "You can move an anchor or, keeping other object constraints in mind,
> position an object relative to it's anchor by dragging the object."

Also +1 from my side

Anchoring and moving objects is not easy to understand and we have several bug reports about it. So I'm not sure how detailed help page should be. But sugestion above are very helpful. Thank you, Ross!
Comment 3 Commit Notification 2021-10-15 19:06:29 UTC
Ross Johnson committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/6079bc0682395542969c2a0e7e184bf89a175428

tdf#145135 - Writer object positioning help page fixes
Comment 4 Dieter 2021-10-30 07:10:38 UTC
VERIFID, see https://help.libreoffice.org/7.3/en-US/text/swriter/guide/anchor_object.html?&DbPAR=WRITER&System=WIN

Ross, thank you for fixing it!