Bug 145146 - LibreCalc 7.1.6.2 Conditional Formatting Range Randomness
Summary: LibreCalc 7.1.6.2 Conditional Formatting Range Randomness
Status: RESOLVED DUPLICATE of bug 133027
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.1.6.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-14 21:36 UTC by Darsh
Modified: 2021-10-15 16:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darsh 2021-10-14 21:36:14 UTC
Description:
For the newest LibreCalc, I have defined a range of cells within a column looking for duplicates. However, I notice that those ranges are not static. They change whenever a copy or cut function is used. Is there a method or option to make those conditional ranges LOCKED?

The function used for these is to create a staff grid based on calendar days. Each column represents a calendar day. There never should be a duplicate initial within a column and so conditions were used to double check any errors not caught visually. But sometimes, the range is modified to exclude a cell within a column. Ex: A3:A29; A31, A49 (or even another column for a particular range!)

Another option that would be interesting is a duplicate could be detected if there is any string of characters that are the same. Ex: AP and AP7-7 would be treated as a duplicate and not different.

Steps to Reproduce:
1. Copy/paste or deleting cells with info
2. Viewing Conditional Formatting under Format and Manage
3. Cell ranges change sporadically

Actual Results:
See description

Expected Results:
Ranges defined in conditional formatting should be locked to only the cell range defined for that condition


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Not that I can think of but willing to provide an example file if needed
Comment 1 m.a.riosv 2021-10-15 16:55:03 UTC

*** This bug has been marked as a duplicate of bug 133027 ***