Bug 145264 - menu “View - HTML Source” radio button control inappropriately applied as a toggle switch
Summary: menu “View - HTML Source” radio button control inappropriately applied as a t...
Status: RESOLVED DUPLICATE of bug 101179
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer Web (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2021-10-21 20:58 UTC by skyhook
Modified: 2021-10-22 15:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description skyhook 2021-10-21 20:58:23 UTC
Description:
The “View - HTML Source” menu item is presented as a radio button when it actually toggles like a checkbox, while still exclusive. When selected it greys alternative radio buttons and but can be toggled to re-enable them. Toggling swaps function between editing and WYSIWIG. 

I believe this implementation is needlessly confusing and the concept should be handled as three radio buttons, pick one, options always present even if disabled. 

It isn't intuitive to toggle a radio button like a checkbox, and if modality is the goal all buttons should all be active while exclusive options. The view toggling effect behaves like a radio button with other radio buttons actually still in play, but only after toggling, the current means to the same end. 

The help file below should be considered part of a repair. Specifically, “or opening an existing one” doesn’t appear possible where “one” is referring to an HTML file. When opened, an existing file of any extension hides the “View - HTML Source” radio button. I believe any menu item should be present while disabled if not selectable, not hidden modality: 
https://help.libreoffice.org/7.0/en-US/text/shared/02/19090000.html?&DbPAR=WRITER&System=UNIX

To compare, note that the style menu works, while not how I wish it was handled, because radio buttons remain evident and give the user a visual affordance to understand what's happening, combining inputs with annunciators. 

Steps to Reproduce:
1. Select menu "File>New>HTML Document"
2. Select menu "View>HTML Source"; option missing without step #1
3. Save dialogue appears, new document returns to editing with !DOCTYPE boilerplate

Actual Results:
Selecting menu "View>HTML Source" will now toggle between code and HTML code and WYSIWIG views. 

Expected Results:
Actual results notwithstanding, this maneuver should be implemented as three radio buttons for HTML/Web/Normal where HTML should remain but disabled if not available. I would never expect to toggle a radio button as the very nature of that control is to be mutually exclusive amongst alternative buttons. 


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Explanation condensed from my exasperated version, with more background, at:
https://ask.libreoffice.org/t/is-a-view-menu-control-applied-inappropriately/69474

I took a very long time to figure out what was actually happening, combining the given interface with the the incorrect help file, before I accidentally toggled the radio button and all became clear. Also noted were the large percentage of help requests from users struggling to understand HTML formats within Writer.
Comment 1 Heiko Tietze 2021-10-22 06:52:48 UTC
Absolutely true, and reported a few times.

But I wonder why anyone would edit HTML with LibreOffice. Isn't it better to remove all this functionality? But better discuss this at the duplicate.

*** This bug has been marked as a duplicate of bug 101179 ***
Comment 2 skyhook 2021-10-22 15:07:05 UTC
Going to the 2016 report, although I can only agree with you in general.