Bug 145474 - FILEOPEN DOCX: Shapes loosing their position when opening in writer
Summary: FILEOPEN DOCX: Shapes loosing their position when opening in writer
Status: RESOLVED DUPLICATE of bug 137825
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2021-10-31 16:36 UTC by forumyok
Modified: 2022-05-23 17:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
writer and mS word difference (1.20 MB, image/jpeg)
2021-10-31 16:36 UTC, forumyok
Details
writer and mS word difference (39.53 KB, application/vnd.oasis.opendocument.text)
2021-11-29 10:09 UTC, forumyok
Details
document (39.53 KB, application/vnd.oasis.opendocument.text)
2021-11-29 10:10 UTC, forumyok
Details
writer and mS word difference (77.10 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-12-07 18:30 UTC, forumyok
Details

Note You need to log in before you can comment on or make changes to this bug.
Description forumyok 2021-10-31 16:36:40 UTC
Created attachment 176043 [details]
writer and mS word difference

There is a compatibility issue.
When the page that I prepared with microsoft word and looks normal is opened with libreoffice writer, some items do not appear and the page layout appears to be shifted.
Comment 1 Dieter 2021-11-15 07:08:54 UTC
Thank you for reporting the bug. Screenshot makes it visible. But please attach a sample document so somebody is able to reproduce the bug. Thank you.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it)
Comment 2 forumyok 2021-11-29 10:09:26 UTC
Created attachment 176561 [details]
writer and mS word difference

i added the document. circles with plus in them seem to have shifted from their places
Comment 3 forumyok 2021-11-29 10:10:51 UTC
Created attachment 176562 [details]
document

i added the document. circles with plus in them seem to have shifted from their places
Comment 4 Dieter 2021-12-06 21:27:09 UTC
Please attach the original docx-file, so I can compare it in Word and Writer. Thank you.
=> NEEDINFO
Comment 5 forumyok 2021-12-07 18:30:53 UTC
Created attachment 176773 [details]
writer and mS word difference

i added docx file.
Comment 6 Dieter 2021-12-07 19:06:12 UTC
(In reply to forumyok from comment #5)
> i added docx file.

Thank you. I confirm the bug with

Version: 7.2.4.1 (x64) / LibreOffice Community
Build ID: 27d75539669ac387bb498e35313b970b7fe9c4f9
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

in comparison to Word 2016.
Comment 7 Gabor Kelemen (allotropia) 2022-05-23 17:15:09 UTC
I see two main issues in this document.

First is that the rectangle shapes are placed next to each other and paragraphs around them are wrapped differently:

* In Word the empty paragraph is wrapping around all shapes horizontally and vertically, so it's below all of them. The circle shapes are all anchored relative to this paragraph, in practice all appear vertically above it.
* In Writer the empty paragraph wraps only the top-left shape and it's rendered next to it. The circle shapes are anchored to this paragraph, so a few cm above this means they appear above the top margin of the page except for those used to be at the bottom, those are still visible. This is the same issue as bug 137825 (and there are likely some others stemming from this difference too...). Let me mark this a duplicate of that one.

Second issue is the colorful tables becoming larger, because their empty cells have in Word a 6 pt font size direct formatting that is not imported in Writer, so the style default 11 pt is applied, making the rows taller.
This was imported correctly in 7.0, broken since 7.1, just bibisected to the same commit as bug 136617.

*** This bug has been marked as a duplicate of bug 137825 ***