Bug 145486 - LO crashes with finalized ooSetupLastVersion
Summary: LO crashes with finalized ooSetupLastVersion
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Homeboy_445
URL:
Whiteboard: target:7.3.0
Keywords: bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2021-11-01 08:57 UTC by Samuel Mehrbrodt (allotropia)
Modified: 2021-11-02 09:55 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
config snippet (401 bytes, application/xml)
2021-11-01 08:57 UTC, Samuel Mehrbrodt (allotropia)
Details
bt with debug symbols (4.82 KB, text/plain)
2021-11-01 11:47 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (allotropia) 2021-11-01 08:57:14 UTC
Created attachment 176051 [details]
config snippet

1. Install the attached config snippet via Extension manager
2. Start Writer

Expected: Writer starts
Actual: LO crashes

This is broken since https://git.libreoffice.org/core/commit/07e269f2596756bf841bbc380929bcffc3ca6bc6

include/unotools/VersionConfig.hxx tries to update officecfg::Setup::Product::ooSetupLastVersion but it fails since it's a finalized property.
Comment 1 Julien Nabet 2021-11-01 11:47:15 UTC
Created attachment 176058 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.

I used gdb and catch throw to find it.
Comment 2 Commit Notification 2021-11-02 06:48:33 UTC
homeboy445 committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ab32d1c01814d576b0b82c99e1849a8a71b12188

tdf#145486: Prevented crash by not updating readOnly value

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.