Bug 145545 - Dragging window from title bar causes it to shrink to 1 pixel wide and a few pixels high.
Summary: Dragging window from title bar causes it to shrink to 1 pixel wide and a few ...
Status: RESOLVED DUPLICATE of bug 125543
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-04 23:26 UTC by Simon Dedman
Modified: 2021-11-05 15:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
appearance after moving, first time (646.83 KB, image/png)
2021-11-04 23:27 UTC, Simon Dedman
Details
appearance after moving, subsequent times (64.82 KB, image/png)
2021-11-04 23:28 UTC, Simon Dedman
Details
appearance after unmaximising (65.10 KB, image/png)
2021-11-04 23:28 UTC, Simon Dedman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Dedman 2021-11-04 23:26:35 UTC
Description:
Dragging a Calc window from its title bar (typically when maximised) causes it to shrink to 1 pixel wide and a few pixels high. If you right click on its panel element and hit 'unmaximise', it widens by one or two pixels, and you can then try to resize it by successfully hitting the right resize pixel, or use alt+right-click-drag which gives you a bit more room for error.

When I tried to reproduce this, initially I couldn't. This led to some extra information. I have 3 screens. If I have Thunar on the right screen, and open a spreadsheet, the spreadsheet opens in the right window and can be dragged to the middle window no problem. If I move thunar to the middle window and open a spreadsheet, it opens in the middle window. If I try to drag it, it collapses into the small box shape. If I repeat this with another sheet, it collapses into the thin line shape.

I have another bug which might affect this, but it's more recent than this bug so I suspect not but for full disclosure: https://gitlab.xfce.org/xfce/xfce4-panel/-/issues/525 My xfce4-panel doesn't span all 3 monitors, only the first.

Earliest release this affects: unknown but it's been here at least 3 years.
I've not customised much with my install.
Currently on xubuntu 21.04, LO version 7.1.6.2.

Attachments to be added once filed.

Steps to Reproduce:
1. Open a spreadsheet in Calc. Maximise it.
2. Try to drag it using the title bar.

Actual Results:
Window size shrinks to a tiny box in the first instance, and a thin line in subsequent instances.

Expected Results:
Window moves normally, possibly is automatically shrunk to some reasonable size but probably doesn't need to.


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Version: 7.1.6.2 / LibreOffice Community
Build ID: 10(Build:2)
CPU threads: 12; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: en-GB (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.1.6-0ubuntu0.21.04.1
Calc: threaded

$ glxinfo | grep OpenGL
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) UHD Graphics 630 (CFL GT2)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 21.0.3
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 21.0.3
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 21.0.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
Comment 1 Simon Dedman 2021-11-04 23:27:45 UTC
Created attachment 176111 [details]
appearance after moving, first time
Comment 2 Simon Dedman 2021-11-04 23:28:07 UTC
Created attachment 176112 [details]
appearance after moving, subsequent times
Comment 3 Simon Dedman 2021-11-04 23:28:27 UTC
Created attachment 176113 [details]
appearance after unmaximising
Comment 4 Michael Warner 2021-11-05 13:50:00 UTC
On my single screen laptop running Linux Mint 20, I am not able to reproduce this.

Version: 7.2.2.2 / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded


$ glxinfo | grep OpenGL
OpenGL vendor string: nouveau
OpenGL renderer string: NVA5
OpenGL core profile version string: 3.3 (Core Profile) Mesa 20.0.8
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.3 (Compatibility Profile) Mesa 20.0.8
OpenGL shading language version string: 3.30
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 20.0.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:


Differences between your setup and mine:
3 screens vs 1 screen
Intel driver vs Noveau driver
xfce vs mate window manager
OpenGL version 4.6 vs version 3.3

Unfortunately, I do not have much knowledge about how the graphics layer works, so I can't help further.
Comment 5 Michael Warner 2021-11-05 13:58:18 UTC
Hmm, this is likely a duplicate of bug 125543, which remains unresolved.

*** This bug has been marked as a duplicate of bug 125543 ***
Comment 6 Simon Dedman 2021-11-05 15:33:47 UTC
It does look like a duplicate of that bug. Thanks Michael