Bug 145563 - LibreOffice and NeoOffice fail to respect each other's selections of Pfeffer Mediaeval due to a ligature in the name
Summary: LibreOffice and NeoOffice fail to respect each other's selections of Pfeffer ...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.1.5.2 release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Substitution
  Show dependency treegraph
 
Reported: 2021-11-05 22:52 UTC by MarjaE
Modified: 2022-11-28 03:36 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
4 lines from LO, 4 lines from NO, same fonts, different renderings (50.41 KB, application/vnd.oasis.opendocument.text)
2022-11-27 04:53 UTC, MarjaE
Details
Screenhost from TextEdit (240.49 KB, image/png)
2022-11-27 14:11 UTC, خالد حسني
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MarjaE 2021-11-05 22:52:03 UTC
Description:
(I don't know if any other fonts run into similar bugs.)

Steps to Reproduce:
1. I use both LibreOffice and NeoOffice because of different accessibility constraints and color palettes. LibreOffice allows me to use spreadsheets without getting migraines from marching ants, and allows me to use consistent color palletes from other LibreOffice projects. NeoOffice allows me to increase text sizes in the preferences, properties, etc. Both currently allow me to disable blinking cursors and some other but not all flashing.

2. Have both LibreOffice and NeoOffice. I don't know if similar behavior occurs with OpenOffice.

3. Install Pfeffer Mediaeval from here: http://robert-pfeffer.net/schriftarten/englisch/nachgeladener_rahmen.html?got_tastaturbelegung.html I installed it in my user Library, using Apple's Font Book application.

4. Create a Writer/.odt or Draw/.odg document in either LibreOffice or NeoOffice, set some fonts to Pfeffer Mediaeval. Using either Characters, or Styles, or both.

Actual Results:
5. Open the same document in either NeoOffice or LibreOffice, whichever you didn't use in step 4, check the fonts. The text shows in Helvetica or Arial or another bland and hard-to-read font. If I check the font info, it's italicized, apparently because the current app can't detect Pfeffer Mediaeval. Go, set fonts again, Pfeffer Mediaeval is in the list, use it.

6. Open the same document in either LibreOffice or NeoOffice, whichever you didn't use in step 5, check the fonts. The text shows in Helvetica or Arial or another bland and hard-to-read font. If I check the font info, it's italicized, apparently because the current app can't detect Pfeffer Mediaeval. Go, set fonts again, Pfeffer Mediaeval is in the list, use it.

7. Each time I fix it in one app, it breaks it in the other.

Expected Results:
8. Since both apps have access to Pfeffer Mediaeval, they should be able to recognize the font when the other app sets it.


Reproducible: Always


User Profile Reset: No



Additional Info:
tested in safe mode, too.
Comment 1 MarjaE 2021-11-06 23:09:23 UTC
The bug is probably in the font rather than in LibreOffice. Because the Postscript Name and Full Name do not include a ligature, but the Font Book name does. Selecting it in LibreOffice, I get one without a ligature, then NeoOffice can't find that, and selecting it in NeoOffice, I get one with a ligature, and LibreOffice can't find that.
Comment 2 خالد حسني 2022-11-27 03:31:50 UTC
Please attach document created with LibreOffice and win NeoOffice. I don’t have NeoOffice, but when I select the font in LibreOffice, I get the font name “Pfeffer Mediæval” which matches what Font Book shows.
Comment 3 MarjaE 2022-11-27 04:53:20 UTC
Created attachment 183826 [details]
4 lines from LO, 4 lines from NO, same fonts, different renderings
Comment 4 خالد حسني 2022-11-27 14:11:02 UTC
Created attachment 183827 [details]
Screenhost from TextEdit

This seems to be a NeoOffice bug, LibreOffice is correctly using the family name while NeoOffice is using the PostScript name which I don’t think is valid for family name.

I’m getting the same result opening the attached file in LibreOffice, OpenOffice and even TextEdit.
Comment 5 خالد حسني 2022-11-27 14:56:51 UTC
Definitely NeoOffice bug, it lists the font twice, once as “Pfeffer Mediæval” and once as “PfefferMediaeval” but the later is not a valid for family name. However, I can’t reproduce your original issue: if I select “Pfeffer Mediæval”, it remains like that when I open the font in LibreOffice.