Bug 145812 - Cell reference are highlighted black when putting = into a cell and clicking a different cell
Summary: Cell reference are highlighted black when putting = into a cell and clicking...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Formula Cell-Reference Cell-Selection
  Show dependency treegraph
 
Reported: 2021-11-21 12:03 UTC by Telesto
Modified: 2021-11-25 09:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screencast (580.95 KB, video/mp4)
2021-11-22 08:49 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-11-21 12:03:59 UTC
Description:
Cell reference are highlighted black when putting = into  a cell and clicking a different cell

Steps to Reproduce:
1. Open Calc
2. Type 5 in A1
3. Enter cell A2
4. Type & click cell A1
5. A1 will be put into cell A2 but appears highlighted/black. 
6. Type say A. Notice this being put behind A1. Which is expected, except the highlighting suggested 'overwrite' mode

Actual Results:
Black background

Expected Results:
Cell background or if this some 'feature', make a different color


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 7.3.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 214fa233338c09156c67f85818b6a2ea6b3235bd
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

and in
3.5.7.2
Comment 1 Telesto 2021-11-21 12:05:43 UTC
UX needed because the current behaviour being present for a long long time.
See for comparison MSO
Comment 2 LeroyG 2021-11-21 16:01:45 UTC
The "highlighting suggested 'overwrite' mode" works for clicking, not for typing nor backspace.

Version: 7.1.7.2 (x64) / LibreOffice Community
Build ID: c6a4e3954236145e2acb0b65f68614365aeee33f
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: default; VCL: win
Locale: es-MX (es_ES); UI: en-US
Calc: CL
Comment 3 Heiko Tietze 2021-11-22 07:36:44 UTC
Cannot follow, please do a screencast.
Comment 4 Telesto 2021-11-22 08:49:18 UTC
Created attachment 176416 [details]
Screencast

Literally my exact steps (different location on the sheet), but the fact the the selected cell becomes 'black' is unfamiliar for me. And well the mixture of 'black' meaning you will overwrite and cases where this isn't the case is rather confusing in my perception. 

LibreOffice is here clearly different from MSO, but no clue if there is a some this is not a bug but feature logic behind it. So I complain about the mere presence of this behaviour, or the implementation of the feature.
Comment 5 Heiko Tietze 2021-11-22 10:53:54 UTC
For sake of consistency we should respect the overwrite mode and delete the whole selection on keypress. However, this was probably implemented intentionally as a convenience feature. Imagine you have to press arrow right when you want to create a formula like =a1+a2+a3+a4...
Comment 6 Heiko Tietze 2021-11-25 09:41:05 UTC
We discussed this topic in the design meeting. 

   + convenience feature if one can click another cell to overwrite 
     but at the same time + to continue a formula
   + MS Excel does behave the same but does not show the selection
   + complaints are rare, behavior exists forever
   + not showing the selection shouldn't hurt too much
   + difference to Excel is that we highlight only the last cell
     while Excel shows a color coding for all, eg. =A1+A2+A3 makes
     the border of A1 red, A2 green, A3 blueish
   + Excel highlighting is also not straight-forward as it misses 
     the overwrite aspect
   + lot of effort for not much benefit

Putting all together we decided to keep the current behavior.