Bug 145851 - Crash in: sw::mark::MarkManager::renameMark(sw::mark::IMark *,rtl::OUString const &) when paste bookmarked into selected bookmarked text
Summary: Crash in: sw::mark::MarkManager::renameMark(sw::mark::IMark *,rtl::OUString c...
Status: RESOLVED DUPLICATE of bug 145621
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-23 13:23 UTC by Ilya Lebedev
Modified: 2021-11-23 14:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature: ["sw::mark::MarkManager::renameMark(sw::mark::IMark *,rtl::OUString const &)"]
Regression By:


Attachments
file containing string with a bookmark (9.02 KB, application/vnd.oasis.opendocument.text)
2021-11-23 13:23 UTC, Ilya Lebedev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya Lebedev 2021-11-23 13:23:17 UTC
Created attachment 176446 [details]
file containing string with a bookmark

When trying to copy text containing bookmark (according to tools > options > formatting aids. Created for example from inserting TOC for heading) and paste in already sected text (replacing) crash occurs.

There is a string with bookmark at the beginning in attached file.
To reproduce a bug:
1. Select full string.
2. Copy (via ctrl+c or from context menu)
3. Select full string again.
4. Paste (via ctrl+v or from context menu)


This bug was filed from the crash reporting server and is br-4a644394-6aa5-44df-b31a-acec5c5192e3.
=========================================

Version: 7.2.2.2 (x64) / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 2; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2021-11-23 14:59:04 UTC
Thanks for reporting this issue.
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=4bf04dea9afb30a9395e80b07a81d1908937ee8b
Which is the same as in bug 145621
Closing as DUPLICATED

*** This bug has been marked as a duplicate of bug 145621 ***