Bug 145880 - Crash in: sw::mark::MarkManager::renameMark(sw::mark::IMark *,rtl::OUString const &)
Summary: Crash in: sw::mark::MarkManager::renameMark(sw::mark::IMark *,rtl::OUString c...
Status: RESOLVED DUPLICATE of bug 145621
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: implementationError
Depends on:
Blocks:
 
Reported: 2021-11-25 05:07 UTC by Vasudev
Modified: 2022-01-11 09:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["sw::mark::MarkManager::renameMark(sw::mark::IMark *,rtl::OUString const &)"]
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vasudev 2021-11-25 05:07:58 UTC
This bug was filed from the crash reporting server and is br-0746d4b9-0eeb-43e6-983b-de9e701c1141.
=========================================

1. Writer was on review mode [track changes -> record]
2. Deleted existing content
3. Replaced with a new content 


4. Copied new content from a different window [Notepad++] 
5. Replaced the content with existing content [refer #3]
6. Writer crashed

For example:

1. Enable track changes [view and record] mode
2. Replace the existing content in Line 15: 'A quick black fox jumps and cries.' with 'A Quick black fox jumps over the lazy dog.'
3. Copy the content from a different window, for example, 'A pangram is a sentence that contains all of the letters of English Alphabet'
4. Replace the content in Line 15
5. Writer crashed. 

Expected Behavior: Copy + Paste behavior

Reproducible: Rarely

Please check the crash report.
Comment 1 Roman Kuznetsov 2021-11-28 12:59:50 UTC
No problem in

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: d272bf4f8f3a083b8c37f7b10f89cd2bf76b7d21
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL

may be only Windows 10 problem?
Comment 2 Xisco Faulí 2022-01-11 09:51:25 UTC
it looks like a duplicate of bug 145621 and it should be fixed in LibreOffice 7.2.5.2

*** This bug has been marked as a duplicate of bug 145621 ***