Bug 145981 - Eliminate the "Document is read-only" warning dialog and merge functionality with infobar
Summary: Eliminate the "Document is read-only" warning dialog and merge functionality ...
Status: RESOLVED DUPLICATE of bug 143971
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-01 02:39 UTC by Jeff D. Hanson
Modified: 2021-12-02 19:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff D. Hanson 2021-12-01 02:39:11 UTC
Description:
Basis:

1. The read-only dialog warning is redundant with the info bar warning.

2. The user experience would be better if the writeability notification was integrated with the infobar and always active (with optional disablement in the config).

3. The dialog is annoying when the file is under control of a VCS or document management system and the user is already aware of the file status when opening it.  When browsing through a bunch of such files it guarantees doubling the number of mouse clicks for access.


It may make sense to combine the read-only infobar with real-time collaboration or CMIS status updates.  While not directly related to the read-only dialog file locking and writeability are the primary contentions in these situations.

Steps to Reproduce:
1. Open read-only file
2.
3.

Actual Results:
Read-only/notification dialog displayed followed by read-only infobar shown

Expected Results:
Option available to skip the the read-only/notification dialog


Reproducible: Always


User Profile Reset: No



Additional Info:
v7.2.3.2 (not in version list)
Comment 1 Roman Kuznetsov 2021-12-02 19:13:47 UTC
It's already fixed in 7.2.4

Close as duplicate

*** This bug has been marked as a duplicate of bug 143971 ***