Bug 146084 - "Missing hyphenation data" is displayed for languages without hyphenation
Summary: "Missing hyphenation data" is displayed for languages without hyphenation
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: All All
: medium normal
Assignee: Hossein
URL:
Whiteboard: target:7.4.0 target:7.3.0.2
Keywords:
Depends on:
Blocks: Hyphenation
  Show dependency treegraph
 
Reported: 2021-12-06 20:25 UTC by Hossein
Modified: 2022-01-21 09:54 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ODT document containing Persian (Farsi) text with fa_IR locale (10.67 KB, application/vnd.oasis.opendocument.text)
2021-12-06 20:28 UTC, Hossein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hossein 2021-12-06 20:25:17 UTC
Description:
Many scripts related to various languages do not use hyphenation at all. In these languages, when a paragraph more than one line is created in the writer, one will see a yellow message on the top of the page after save and reload with this text:

'Missing hyphenation data Please install the hyphenation package for locale "ab_CD".'

in which 'ab_CD' is the locale.

The list of languages with the hyphenation support in the LibreOffice can be found here:
https://wiki.documentfoundation.org/Language/Support

Some of the known languages with the hyphenation are listed here:
https://developer.mozilla.org/en-US/docs/Web/CSS/hyphens

And some of the known languages without the hyphenation are as follows:
* Arabic (all countries)
* Persian
* Pashto
* Japanese (reported in Bug 143422)

The list is bigger, and other languages that do not support hyphenation should be added to this list.

Steps to Reproduce:
1. Open the attachment hyphen.odt

Actual Results:
You will see the yellow bar on the top of LibreOffice Writer saying:
'Missing hyphenation data Please install the hyphenation package for locale "fa_IR".'

Expected Results:
Nothing should be displayed about lack of the hyphenation data, because the language does not support hyphenation at all.


Reproducible: Always


User Profile Reset: No



Additional Info:
Attachment hyphen.odt contains Persian language, but the same is true for the other listed languages.
Comment 1 Hossein 2021-12-06 20:28:42 UTC
Created attachment 176746 [details]
ODT document containing Persian (Farsi) text with fa_IR locale
Comment 2 Shantanu 2021-12-07 03:17:46 UTC
Reproduced using:

Version: 7.1.4.2 (x64) / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 1; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

Getting alert about "Missing hyphenation data".
Comment 3 Kevin Suo 2021-12-07 06:12:53 UTC
I once encountered the same issue with Simplified Chinese language. We should hide this for the following languages also:

71  #define LANGUAGE_CHINESE_HONGKONG
172  #define LANGUAGE_CHINESE_LSO
173  #define LANGUAGE_CHINESE_MACAU
174  #define LANGUAGE_CHINESE_SIMPLIFIED
175  #define LANGUAGE_CHINESE_SINGAPORE
176  #define LANGUAGE_CHINESE_TRADITIONAL
177  #define LANGUAGE_CHINESE_SIMPLIFIED_LEGACY
178  #define LANGUAGE_CHINESE_TRADITIONAL_LSO
179  #define LANGUAGE_CHINESE

However I think only LANGUAGE_CHINESE_SIMPLIFIED and LANGUAGE_CHINESE_TRADITIONAL are used, so checking these two only is enough.

Aslo I think LANGUAGE_KOREAN also does not need hyphenation.
Comment 4 Po-Yen Huang 2021-12-08 02:46:13 UTC
(In reply to Kevin Suo from comment #3)
> I once encountered the same issue with Simplified Chinese language. We
> should hide this for the following languages also:
> 
> 71  #define LANGUAGE_CHINESE_HONGKONG
> 172  #define LANGUAGE_CHINESE_LSO
> 173  #define LANGUAGE_CHINESE_MACAU
> 174  #define LANGUAGE_CHINESE_SIMPLIFIED
> 175  #define LANGUAGE_CHINESE_SINGAPORE
> 176  #define LANGUAGE_CHINESE_TRADITIONAL
> 177  #define LANGUAGE_CHINESE_SIMPLIFIED_LEGACY
> 178  #define LANGUAGE_CHINESE_TRADITIONAL_LSO
> 179  #define LANGUAGE_CHINESE
> 
> However I think only LANGUAGE_CHINESE_SIMPLIFIED and
> LANGUAGE_CHINESE_TRADITIONAL are used, so checking these two only is enough.
> 
> Aslo I think LANGUAGE_KOREAN also does not need hyphenation.

Yeah, CJK don't use hyphenation, so maybe add all of them are good idea.
Comment 5 sophie 2021-12-09 14:27:48 UTC
I'll ask on l10n list if there are more languages to take into account and will report here.
Comment 6 Christian Lohmaier 2021-12-13 11:35:37 UTC
https://gerrit.libreoffice.org/c/core/+/120497/ has a fix for Japanese, but for a fix for all the affected languages, please consider a sepearate list NO_HYPHENATION_LANGS or similar to group them and not add them all to the if statement directly for better readability/maintainability.
Comment 7 Eike Rathke 2021-12-17 12:59:50 UTC
See also my comment there (in https://gerrit.libreoffice.org/c/core/+/120497/) from Nov 08 23:19
Comment 8 Po-Yen Huang 2021-12-23 05:49:10 UTC
Could anyone check why this request have error?
https://gerrit.libreoffice.org/c/core/+/127204
Comment 9 Kevin Suo 2021-12-23 07:05:00 UTC
> Build Failed 
> 
> https://ci.libreoffice.org/job/gerrit_master/103484/ : FAILURE
> 
> Killed by the kill-wrapper, typically due to no stdout/-err activity during a specified timeout interval. ( https://ci.libreoffice.org/job/gerrit_linux_clang_dbgutil/103674/ )

This may due to an error on the build server. You may: 1) Rebase that commit to the current master, so that the build will restart; or 2) to to IRC channel to ask someone to rerun the build.
Comment 10 Hossein 2022-01-02 17:30:36 UTC
Please help completing the LO hyphenation support status in the Wiki:

    https://wiki.documentfoundation.org/Language/Support

Use this:

    y = yes (Hyphenation for the language is supported in LO)
    n = no  (The language uses hyphenation, but LO does not support it)
    n/a = non applicable (The language does not use hyphenation)

Many of the table cells are now filled with '?' which means "unknown" which is not usable.
Comment 11 Commit Notification 2022-01-07 20:39:47 UTC
Hossein committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/151c56ed547490a99d912524c0e56b5d6d4a1939

tdf#146084 Don't warn for languages without hyphenation

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2022-01-09 03:58:32 UTC
Hossein committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7650d164a1e9c34ce99bf30bf4198e7ceb21fb5d

tdf#146084 No hyphenation warning for Vietnamese

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2022-01-09 12:23:12 UTC
Hossein committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/139ad1049ca65b279fe5e0b085bf2af039b62e19

tdf#146084 Don't warn for languages without hyphenation

It will be available in 7.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2022-01-09 17:51:08 UTC
Hossein committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7ac5ee3546e15455c5ee306af234bb7fe8a29049

tdf#146084 No hyphenation warning for Pashto

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2022-01-09 20:14:44 UTC
Hossein committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/4b0b5adf22ee479258a2625d6d12d81160f247d0

tdf#146084 No hyphenation warning for Pashto

It will be available in 7.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2022-01-10 12:29:27 UTC
Hossein committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/98eea4c8c73a05114ec831a18ef8b3eed9a574da

tdf#146084 Test for languages without hyphenation

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 BogdanB 2022-01-21 01:39:07 UTC
Hossein, hi. This bug looks like it is solved, but it is in assigned status. Could you update? Thanks.
Comment 18 Hossein 2022-01-21 09:54:55 UTC
(In reply to BogdanB from comment #17)
> Hossein, hi. This bug looks like it is solved, but it is in assigned status.
> Could you update? Thanks.
This is now fixed for all the languages that was known to be affected. I am marking this as fixed. If any other language is remaining, this can be re-opened.