Bug 146104 - DATA LOSS when pressing tab to add a row in a table in writer
Summary: DATA LOSS when pressing tab to add a row in a table in writer
Status: RESOLVED DUPLICATE of bug 126008
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.7.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2021-12-07 18:38 UTC by Pierre C
Modified: 2022-03-08 10:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test file (13.74 KB, application/vnd.oasis.opendocument.text)
2021-12-07 18:38 UTC, Pierre C
Details
Video showing the bug (678.06 KB, video/mp4)
2021-12-07 18:40 UTC, Pierre C
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre C 2021-12-07 18:38:21 UTC
Created attachment 176774 [details]
test file

Step to reproduce :
Open test file
Go to last cell and press TAB to add a row

=> All KNX addresses are changed

It should not

CTRL doesn't work (row is deleted, but values stay)

Same problem with LO 7.3 dev & LO 7.8.1 Both Windows 10
Comment 1 Pierre C 2021-12-07 18:40:46 UTC
Created attachment 176775 [details]
Video showing the bug
Comment 2 Pierre C 2021-12-07 18:50:12 UTC
Sorry version 7.1.8.1 not 7.8.1
Comment 3 Pierre C 2021-12-17 08:58:43 UTC
This is a very annoying bug as CTRL Z doesn't work, and so data some data are lost. You have to choose between your last changes since last saved doc and lost in the table.

Also it happens when deleting a row

This bug is linked to Table style, with no table style, no problem
Comment 4 Paolo Vecchi 2021-12-18 09:52:38 UTC
I've been able to reproduce it in version 7.2.4.1

The issue is related to the style changing the cells format from text to number-standard when adding a new row.

The workaround for me has been to create a new style from the existing one using Autoformat Styles but I've unticked the "Number format" checkbox, applied the style to the table and now it adds new lines without changing the number format preserving the original values.
Comment 5 Timur 2022-01-07 14:09:39 UTC
No repro 6.4.0, repro 7.0.0. Regression in Linux-7.0. 

commit 131b23e24d6a2731df74afa57acffe61ab1ee50c
Date:   Thu Feb 27 19:26:45 2020 +0100
    source sha:59ace23c367f83491a37e844d16f7d716eff6346
    prev sha:5352d45dd4a04f8f02cf7f6ad4169126d3b3586a

author	Maxim Monastirsky <momonasmon@gmail.com>	2020-02-21 
committer	Michael Stahl <michael.stahl@cib.de>	2020-02-27 
tdf#101710 Fix invalid style:data-style-name attribute

CC: Maxim. Please see.
Comment 6 Jean-Baptiste Faure 2022-01-13 22:14:33 UTC
Already reproducible in LO 6.4.7 :

Version: 6.4.7.2
Build ID: 1:6.4.7-0ubuntu0.20.04.2
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: gtk3; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

Best regards. JBF
Comment 7 Jean-Baptiste Faure 2022-01-13 22:17:24 UTC
Dataloss -> Major as ctrl+Z does not restore original content of the cells wrongly interpreted as dates and converted in serial numbers.

Best regards. JBF
Comment 8 Maxim Monastirsky 2022-03-08 10:51:29 UTC
My commit just fixed the ODF import of the number format specified in the table style, thus *preventing* data loss. What happens afterwards seems to be yet another instance of Bug 126008.

Here is how to repro this *without* my commit:

1. Open Writer.
2. Tools > Options... > Language Settings > Languages, change "Locale setting" to "French (France)".
3. Insert a 3x2 table.
4. Apply the "Academic" table style to it.
5. Place the cursor into the middle cell of the last row, and type "1.1.151"
6. Press TAB twice.

Also repro with:

Version: 6.4.0.3
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 4; OS: Linux 5.16; UI render: default; VCL: gtk3; 
Locale: fr-FR (en_US.UTF-8); UI-Language: en-US
Calc: threaded

*** This bug has been marked as a duplicate of bug 126008 ***