Bug 146197 - Libre office Calc 7.2.2 Crash when a checkbox is relative to a cell and modify the size of a column
Summary: Libre office Calc 7.2.2 Crash when a checkbox is relative to a cell and modif...
Status: RESOLVED DUPLICATE of bug 144244
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-12 19:52 UTC by LVO
Modified: 2021-12-13 19:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Image to get the bug (167.50 KB, image/png)
2021-12-13 17:50 UTC, LVO
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LVO 2021-12-12 19:52:27 UTC
Description:
When a checkbox is relative to a cell, not to the page by default, the program crash when we want to save the sheet and the spreadsheet.

The problem is reproductible with a new spreadsheet.

Steps to Reproduce:
1. create a new file
2. Insert a new checkbox
3. Modify relative to page to relative to cell
4  Modify the size of a column
5 Save the file

Actual Results:
Crash of software.

Expected Results:
Crah of the software


Reproducible: Always


User Profile Reset: No



Additional Info:
Tested with Debien buster.
Tested with Distro Antix.
Not tested with windows.

Open Gl on Debian is :
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 7.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.3.6
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.1 Mesa 18.3.6
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.3.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
Comment 1 Xisco Faulí 2021-12-13 15:21:35 UTC
I can't reproduce it in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: b8b72fdbbba57c017fcc3bce09fe8da31826aa2a
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

You mean, Anchor - To Cell ?
Comment 3 Xisco Faulí 2021-12-13 19:55:52 UTC
Thanks.
It looks like a duplicate of bug 144244, which is fixed in LibreOffice 7.2.5, due to be released in a few weeks.

*** This bug has been marked as a duplicate of bug 144244 ***