Bug 146227 - Writer: Serial Letter Assistant crashes when printing more than 2 adresses
Summary: Writer: Serial Letter Assistant crashes when printing more than 2 adresses
Status: RESOLVED DUPLICATE of bug 144565
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.4.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected
Depends on:
Blocks:
 
Reported: 2021-12-14 18:40 UTC by Peter Gierschner
Modified: 2022-01-19 14:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: https://crashreport.libreoffice.org/stats/crash_details/8d25abb4-553a-4b58-998d-21ed06963971
Regression By:


Attachments
a short file for printing adresses from a Calc-file on envelopes (17.50 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-12-14 18:43 UTC, Peter Gierschner
Details
Umschlag.odt (178.54 KB, application/vnd.oasis.opendocument.text)
2021-12-18 10:17 UTC, Peter Gierschner
Details
Short testfile with adress data (9.27 KB, application/vnd.oasis.opendocument.spreadsheet)
2022-01-02 10:21 UTC, Peter Gierschner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Gierschner 2021-12-14 18:40:52 UTC
Description:
When starting a serial printing the assistant crashes and with it all open Libreoffice threads. Single Letters are processed ok, but if I want to print more than 2 letters the crah occures

Steps to Reproduce:
1.Start the assistant
2.chose the desired range in the databas (in my case: adresses in a Calc file
3.

Actual Results:
Crash of all open Libreoffice threads

Expected Results:
Printing the serial letters


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Will try to append the textfile and the adress data
Comment 1 Peter Gierschner 2021-12-14 18:43:37 UTC
Created attachment 176930 [details]
a short file for printing adresses from a Calc-file on envelopes
Comment 2 Peter Gierschner 2021-12-18 10:17:19 UTC
Created attachment 176993 [details]
Umschlag.odt
Comment 3 Dieter 2022-01-02 08:45:18 UTC
Peter, thank you for the report. I can't confirm the crash with

Version: 7.3.0.1 (x64) / LibreOffice Community
Build ID: 840fe2f57ae5ad80d62bfa6e25550cb10ddabd1d
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Could you please specify steps, for example
1. Open attached document
2. Tools -> Mail Merge Wizard
3. Connect document with provided databese
...

Please also add complete


=> NEEDINFO

But the most important thing: Your database contains personal data informations. That's very critical. Please delete this file (I don't know how tis is possible in LO and use a short database with dummy addresses instead!!!)
Comment 4 Peter Gierschner 2022-01-02 10:21:52 UTC
Created attachment 177241 [details]
Short testfile with adress data
Comment 5 Peter Gierschner 2022-01-02 10:31:17 UTC Comment hidden (me-too)
Comment 6 Peter Gierschner 2022-01-02 10:33:11 UTC
1 Open the file Umschlag.odt, contains a textfield which contais two datafields corresponding to the adress data
2 click on "Print", write asks if you want to make a serial letter -> yes
3 serial letter assistant opens -> click ALL and PRINTER
4Printing starts, but crashes after a few seconds
Comment 7 Dieter 2022-01-02 11:57:04 UTC
Thank you for the steps, but perhaps I'm not familiar enough with that topic. If I press "Yes" (for question "Do you want to print a form letter?"), a "Data source Not Found" windows opens. I select "Check Connection Settings" and I can see the database dialog in LO options. I couldn't find a way to select ods-file as database.
Comment 8 Timur 2022-01-19 11:24:40 UTC
I reproduced with 7.2 but not with 7.3 and master 7.4+, so seems fixed, I mark WFM.

Note: Please attach files only with English alphabet, in my case I couldn't save "fur" so I had more steps to adjust.
Comment 9 Timur 2022-01-19 11:42:56 UTC
Peter, please use LO 7.2.5.2. 
If OK there, maybe a duplicate of bug 144565.
Comment 10 Peter Gierschner 2022-01-19 11:56:15 UTC
Sorry, can´t test anymore, my update to 7.3.0.2 ist just running ...
Comment 11 Timur 2022-01-19 13:45:43 UTC
I tried with the commit and really seems duplicate.

*** This bug has been marked as a duplicate of bug 144565 ***
Comment 12 Peter Gierschner 2022-01-19 14:02:18 UTC
With 7.3.0.2 it works !