Bug 146546 - Calc unusably slow after adding a column of SUMIF
Summary: Calc unusably slow after adding a column of SUMIF
Status: RESOLVED DUPLICATE of bug 144777
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) rc
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2022-01-03 13:26 UTC by Shad Sterling
Modified: 2022-01-14 17:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Shad Sterling 2022-01-03 13:26:56 UTC
I wanted to add partial sums to a ~100KB .ods file, so I added column AC so cell AC_n contains `=SUMIF(O$2:O$999,O_n,X$2:X$999)`.  The values are correct, but after adding that column it takes a few seconds to do anything in this file, including switching back to LibreOffice from another app, moving which cell is selected, scrolling, copying a cells to the clipboard, etc, etc

Steps to Reproduce:
Add a column of SUMIFs as described in Description

Actual Results:
Everything is horribly slow as described in Description

Expected Results:
Responsiveness shouldn't change.  At most, recalculations might take longer, but actions that don't make any changes should not be affected

Reproducible: Always

User Profile Reset: No

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Mac OS X (All)
OS is 64bit: no
[Copied from About LibreOffice]
Version: / LibreOffice Community
Build ID: 840fe2f57ae5ad80d62bfa6e25550cb10ddabd1d
CPU threads: 16; OS: Mac OS X 10.16; UI render: Skia/Metal; VCL: osx
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
[OS Info]
macOS Big Sur 11.6.2
[Things I tried]
Based on forum posts I tried to disable OpenGL, but it looks like the options have changed so that there's no OpenGL option.
I disabled hardware acceleration, anti-ailiasing, and using Skia for all rendering, with no discernible effect.
Multi-threaded calculation is enabled
Comment 1 m_a_riosv 2022-01-03 22:45:43 UTC
Please, attach a sample file.

BTW, I think it's OpenCL in the options, not OpenGL, the last it's about Graphics in View,

Comment 2 Shad Sterling 2022-01-05 01:00:39 UTC
OpenCL was already disabled

After it got slow I tried restarting the app, upgrading from Dev to Prerelease, fiddling with the settings and restarting multiple times, all with no effect, so I filed this bug.  Since then LibreOffice crashed on its own, and after restarting from the crash it's not being unusably slow anymore.  I guess something got into a bad state that persisted across all the restarts, the upgrade, and the settings changes, but got reset by the crash.

I'm not going to share the financial records I was working with when it happened, if the formula that triggered the problem isn't useful how do I construct a suitable sample?
Comment 3 QA Administrators 2022-01-05 03:41:05 UTC Comment hidden (obsolete)
Comment 4 Luboš Luňák 2022-01-12 14:18:44 UTC

*** This bug has been marked as a duplicate of bug 144777 ***
Comment 5 Shad Sterling 2022-01-14 17:11:44 UTC
I'm not sure this is a duplicate of bug 144777; it happened again yesterday making a similar change to a different file (this time with COUNTIF), and the calculation took at most a few seconds, but it made the app (Prerelease unusable for the rest of the day.  I left it overnight to see if it would finish, and this morning it was still unusable; I told it to close about 4 hours ago and it never finished closing.  After forcequitting just now it did not bring up the document recovery, and it seems to have recovered and be updating the COUNTIF cells with no noticable delay