Bug 146597 - Writer stops responding when a group of shapes is anchored to character
Summary: Writer stops responding when a group of shapes is anchored to character
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.3.2 release
Hardware: All All
: high major
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:7.4.0 target:7.3.2 target:7.2.7
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Shapes
  Show dependency treegraph
 
Reported: 2022-01-05 18:29 UTC by phv
Modified: 2022-03-10 12:35 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Testcase document (13.00 KB, application/vnd.oasis.opendocument.text)
2022-01-05 18:31 UTC, phv
Details
Video showing the bug (1.19 MB, video/mp4)
2022-01-05 18:32 UTC, phv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description phv 2022-01-05 18:29:37 UTC
Description:
The patch for bug #141220 (fix textbox popped out of off-page shape) introduced a lot of issues in the positioning of groups of shapes to the point that it is now impossible to maintain flowcharts position in Writer. While I was investigating the bug #145282, I reproduce this one.

Here, repositioning the group to its anchor hinders the rendering when the first line or the group is selected. I just cannot display the bottom of the page. With the safe mode turned off, this document makes the software stop responding.

This bug does not affect version 7.2.2.2. I guess it appeared in version 7.2.3, when the patch changed the calculation for the position of groups.

Steps to Reproduce:
1. Open the document named "LibreOffice stops responding".
2. Select either the first line or the group.
3. Trying moving the view to the bottom of the page.

Actual Results:
Writer lags and hangs the view while the group seems to have several ghost positions. In some cases, Writer stops responding.

Expected Results:
The positioning of the group should not prevent the view, the software should have a lag-free rendering.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
This bug can also be reproduced on a new document by creating a complex group anchored to character or paragraph, changing the vertical position "From bottom" then edit top wrap.

I would be grateful if you could remove the patch corresponding to the bug #141220 given the many issues it causes: the anchoring of group containing complex shapes (lines and textboxes) has been messed up badly since it was added, and my attempts to find a workaround have all failed (I only found more issues).
Comment 1 phv 2022-01-05 18:31:25 UTC
Created attachment 177331 [details]
Testcase document
Comment 2 phv 2022-01-05 18:32:26 UTC
Created attachment 177332 [details]
Video showing the bug
Comment 3 m.a.riosv 2022-01-05 22:07:30 UTC
Reproducible.
Version: 7.3.0.1 (x64) / LibreOffice Community
Build ID: 840fe2f57ae5ad80d62bfa6e25550cb10ddabd1d
CPU threads: 4; OS: Windows 10.0 Build 21390; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: CL

Even worse dropdown from menu are blank.
Comment 4 phv 2022-01-19 15:40:09 UTC
I would appreciate it if a contributor could perform a bibisect to confirm the source of the issue. Thanks in advance.
Comment 5 Timur 2022-02-10 15:26:40 UTC
I confirm the regression from source 8ee4fb4db4091c3645c994ee741e63c2e1f98b30.
Daniel, please see.
Comment 6 Miklos Vajna 2022-02-16 15:29:42 UTC
Did you mistype the git hash? It's helpful if you just link the commit.
Comment 8 Miklos Vajna 2022-02-17 15:33:31 UTC
Thanks!
Comment 9 Commit Notification 2022-02-25 10:22:23 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e835c2c0d3aff4f1ee5d29c9eaf36400b1aca6a7

tdf#146597 sw: fix freezing with GroupShape

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2022-02-28 09:01:11 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/e38ab299c109766a5a431e5c0fb6b2c59ae3025c

tdf#146597 sw: fix freezing with GroupShape

It will be available in 7.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Timur 2022-02-28 10:23:04 UTC
I set Verified. Thanks for speedy fix. 
Please explain about backport to 7.2.
Comment 12 Attila Bakos (NISZ) 2022-03-07 12:28:40 UTC
(In reply to Timur from comment #11)
> I set Verified. Thanks for speedy fix. 
> Please explain about backport to 7.2.

you are welcome!

The backpost waits there: https://gerrit.libreoffice.org/c/core/+/130715
Comment 13 Commit Notification 2022-03-10 12:35:51 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/d691e9ef4d77cf5e46aec288d5efcf9291534352

tdf#146597 sw: fix freezing with GroupShape

It will be available in 7.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.