Bug 146749 - One document cause LO to crash when scrolling.
Summary: One document cause LO to crash when scrolling.
Status: RESOLVED DUPLICATE of bug 145321
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.3.0.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Ryan
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-13 19:40 UTC by Ryan
Modified: 2022-02-11 04:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The file causing the crash. (8.88 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2022-01-14 21:05 UTC, Ryan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan 2022-01-13 19:40:13 UTC
Description:
 
LO was crashing when I scrolled on one particular document. I tested on other documents and they did not cause the issue.
I did a manual install of LO. I then uninstalled LO and installed via the PPA. This did not help.
I then restarted LO in safe mode but this did not change anything.

I created a copy of the doc in odt (save as) and docx but both of these copies behaved exactly the same. When I copy the content form LO, writer crashes.

Steps to Reproduce:
1.Open LO and use the menu to open the above mentioned document or use the CLI to open the document.
2. Scroll up or down.


Actual Results:
Writer crashes, restarts and asks to do a recovery. The recovered document behaves the same.

Expected Results:
The document does not crash when I scroll.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Additional Info:
I am on Ubuntu 22.04 Linux 5.15.0-16-generic #16-Ubuntu SMP Sat Jan 8 10:05:40 UTC 2022 x86_64
Running sway 1.5.1
Comment 1 Ryan 2022-01-13 19:42:50 UTC
I cannot share the document publicly as it has work-related content. Please let me know if there is some other info I can provide.
Comment 2 Telesto 2022-01-14 10:09:25 UTC
@Xisco
(In reply to Ryan from comment #1)
> I cannot share the document publicly as it has work-related content. Please
> let me know if there is some other info I can provide.

Is possible to arrange something here? For example sharing in private (if acceptable for Ryan)?
Comment 3 Timur 2022-01-14 11:40:12 UTC
Sharing in private could be useful only if duplicate, but not otherwise, as seen in other bugs where that was done.
Ryan, you may anonymize document with replacing all chars with x, testing to see if it crashes.
Without it, bug can only be closed.
Comment 4 Ryan 2022-01-14 17:00:48 UTC
Hello 
I tried replacing all characters with x, it crashes as I try. I am guessing that when the doc gets to the bit that causes the issue, it crashes.

I don't understand what you meant by 'in duplicate'...

I couldn't find a crash report in the crash folder.
Comment 5 Xisco Faulí 2022-01-14 17:03:21 UTC
it looks like a duplicate of bug 145321

*** This bug has been marked as a duplicate of bug 145321 ***
Comment 6 Xisco Faulí 2022-01-14 17:03:53 UTC
Thanks for reporting the issue BTW ;-)
Comment 7 Ryan 2022-01-14 21:05:08 UTC
Created attachment 177553 [details]
The file causing the crash.
Comment 8 Telesto 2022-01-14 22:17:26 UTC
Confirm crash
swlo!sw::MetaFieldManager::getDocumentProperties+0x8932:

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 45dee329c30f5548b0ba57cc1457c73f2fc870a3
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

It looks like Xisco being right about being a duplicate of bug 145321

*** This bug has been marked as a duplicate of bug 145321 ***
Comment 9 Ryan 2022-02-11 04:09:51 UTC
I have tried opening the problem file with the 7.3.1.0.0 daily build and it does not crash when I get to the problem line.

Thanks for all the help!