Bug 146864 - Font not embedded into fill-in-form in the PDF File.
Summary: Font not embedded into fill-in-form in the PDF File.
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
(earliest affected) release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2022-01-19 22:32 UTC by melixane
Modified: 2022-01-20 16:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description melixane 2022-01-19 22:32:29 UTC
When I created a fill – in – form with libre office Writer, I have notice that there is a problem when a Text Box is added, the font is not the same in the PDF file as in the Writer document. 

I have tried to embedded the font when I create a PDF. I have experimented with adobe reader and Foxit reader and it’s the same thing. I can see the original font in my writer document, but not in my PDF file. 

I have also tried it with other fonts and it’s the same thing, we can’t see it in the PDF. I have been updating the software regularly.

Although, if I have tried a list box or a combo box with the same original font, it’s the same in the PDF and in the document.

So How do I fix this problem....

Thank you ....

Steps to Reproduce:
1.Steps at in the message

Actual Results:
Still the same...

Expected Results:
To fix the problem

Reproducible: Always

User Profile Reset: No

Additional Info:
It use to work well, but after a couple of updates it doesn't work like it use to.
Comment 1 melixane 2022-01-20 02:34:43 UTC
I have just checked a couple of PDF fill in forms that I have created a while back ... The fonts were the same as the document... I notice it was made with a libre office 7.0... 

I hope it helps....
Comment 2 V Stuart Foote 2022-01-20 16:37:58 UTC
This is expected since LO 7.1 release

See work done for bug 50879 "PDF export: ensure only built-in fonts are used for forms Alternative would be to embed the whole font, which is unusual: PDF
typically just embeds the used subset."


If you want your LO ODF document to match, use one of the PostScript "Core" fonts (i.e. a font any PDF renderer is required to support)--the default is Helvetica, but Times should behave.