Bug 146891 - Crash (assert) when opening the paragraph properties from an outline
Summary: Crash (assert) when opening the paragraph properties from an outline
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.4.0 target:7.3.1
Keywords:
Depends on:
Blocks: Crash-Assert
  Show dependency treegraph
 
Reported: 2022-01-21 08:57 UTC by Heiko Tietze
Modified: 2022-01-24 08:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2022-01-21 08:57:02 UTC
Insert some text, make it a heading, show the paragraph properties => crash

Debugger stops at in SwParagraphNumTabPage::Reset() at

            // tdf#145804 show "Chapter Numbering"
            assert(!m_xNumberStyleBX->get_sensitive() && "pseudo entry shouldn't be editable");

Happens for all VCL.

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 87fe449c4c1ed46003e9d5fdaf1919f11a53b959
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: gtk3
Locale: de-DE (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2022-01-21 09:33:35 UTC
I can't reproduce it in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: bd5492275d31f59b1d269205018d1487af52426f
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: es-ES (es_ES.UTF-8); UI: en-US
Calc: threaded

@Heiko, please check the steps are complete and you can reproduce it with a clean profile
Comment 2 Heiko Tietze 2022-01-21 09:37:40 UTC
Crashes with latest master and clean profile in safe-mode (kf5 this time).
Comment 3 Timur 2022-01-21 10:00:50 UTC
No repro 7.4+ GTK3 and Windows. 
I undestood this is about experimental Outline and Format-Paragraph. 
Please try with fresh profile or find a missing detail.
Comment 4 Heiko Tietze 2022-01-21 10:34:21 UTC
Nope, gtk3 is also affected for me. Tested in safe-mode. 

Assertion `!m_xNumberStyleBX->get_sensitive() && "pseudo entry shouldn't be editable"' failed.
Comment 5 Caolán McNamara 2022-01-21 16:10:47 UTC
I can reproduce, it's an assert so it needs a build like dbgutil where that is enabled
Comment 6 Commit Notification 2022-01-21 19:54:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f05f92f09d99c48a96a3ef18943c265a803e3820

tdf#146891 there is a case where "chapter numbering" can be changed

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2022-01-22 03:48:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/da3931fac6388716de4ac7cd402f635dc0b377e9

tdf#146891 there is a case where "chapter numbering" can be changed

It will be available in 7.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Heiko Tietze 2022-01-24 08:50:44 UTC
Thanks for fixing so quickly!