Bug 146893 - Make navigation buttons in "Manage Changes" dialog appear only in the List tab
Summary: Make navigation buttons in "Manage Changes" dialog appear only in the List tab
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.2.2 release
Hardware: All All
: medium normal
Assignee: Rafael Lima
URL:
Whiteboard: target:7.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-21 12:13 UTC by Rafael Lima
Modified: 2022-02-18 17:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Current and proposed layouts (46.11 KB, application/vnd.oasis.opendocument.graphics)
2022-01-21 12:13 UTC, Rafael Lima
Details
Manage Changes sidebar with duplicated buttons (18.26 KB, image/png)
2022-01-28 14:00 UTC, Rafael Lima
Details
Sidedbar height options (98.11 KB, application/vnd.oasis.opendocument.graphics)
2022-01-31 11:39 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2022-01-21 12:13:17 UTC
Created attachment 177687 [details]
Current and proposed layouts

The "Manage Changes" dialog used in Writer and Calc has navigation buttons at the bottom, but they appear both in the List and Filter tabs. However, these buttons are only needed in the List tab.

In the attached file I show the current layout and present a new layout for the dialog, with the following main characteristics:

1) The navigation buttons appear only in the List tab
2) A contextualized Help button is added to the dialog
Comment 1 Heiko Tietze 2022-01-21 12:51:58 UTC
/me thumbs up
Comment 2 Commit Notification 2022-01-24 17:17:07 UTC
rafaelhlima committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2e1a38ceb6866248ec30f6fe58cd3adc1b910eec

tdf#146893 Rework Manage Changes dialog

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Rafael Lima 2022-01-28 14:00:12 UTC
Created attachment 177876 [details]
Manage Changes sidebar with duplicated buttons

After the patch, the buttons in the Manage Changes sidebar became unnecessary because they're now embedded in the dialog itself. They need to be removed from the sidebar or else they'll appear duplicated (as in the attached image).

Note that this sidebar is only visible if "Enable experimental features" is checked in Tools - Options - LibreOffice - Advanced.

I submitted a new patch that fixes this issue:
https://gerrit.libreoffice.org/c/core/+/129103/2
Comment 4 Rafael Lima 2022-01-31 11:39:10 UTC
Created attachment 177930 [details]
Sidedbar height options

The proposed change in gerrit that fixes the sidebar issue uses the line of code below in ctredlin.cxx, which fixes width and height to 400px:

pTreeView->set_size_request(400, 400);

The reason why I set a fixed height is due to situations where the document has many changes in the list (see the attached ODG file). The screenshot on the left shows that by fixing the height, a scrollbar appears in the dialog to handle changes that exceed the dialog height.

However, using "-1" for the height causes the dialog within the sidebar to expand beyond the visible area (see the screenshot on the right side of the ODG), causing a scrollbar to appear in the sidebar (not in the dialog).

Ideally, I would like to have the dialog occupy all the available height of the sidebar, without exceeding it, similar to what the Styles sidebar does. However I still could not figure out how.
Comment 5 Commit Notification 2022-02-04 18:03:45 UTC
rafaelhlima committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c7923851d10e2dda9deb414dee67c4813d93bc87

tdf#146893 Remove extra buttons from Manage Changes sidebar

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Rafael Lima 2022-02-18 17:12:42 UTC
FIXED. Tested in:

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 60f786bde4524bbba462eccc6578715f39020076
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: CL