Bug 146910 - [UI Enhance] ease to use the same font for Western and Asian
Summary: [UI Enhance] ease to use the same font for Western and Asian
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2022-01-22 00:45 UTC by Naruhiko Ogasawara
Modified: 2022-03-30 08:44 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
MS font selection dialog (20.44 KB, image/png)
2022-01-24 12:20 UTC, Hossein
Details
All scripts option in MS Word (22.55 KB, image/png)
2022-01-24 12:45 UTC, Hossein
Details
Test Layout for Choice of using same font (59.00 KB, application/pdf)
2022-02-17 04:08 UTC, JO3EMC
Details
Test Layout for Choice of using same font (rev1) (55.46 KB, application/pdf)
2022-02-17 04:31 UTC, JO3EMC
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Naruhiko Ogasawara 2022-01-22 00:45:04 UTC
Description:
In the old days, most the popular CJK fonts often have very ugly Western font glyphs, so we had preferred to use combined font families (such as Century for Western and MS-Mincho for Asian).

Nowadays, several CJK fonts (like Noto Sans/Serif CJK, Yu-Mincho) contain good font glyphs for Western.  So we would like to use the same font for Western and Asian, but at this time, the easiest way to do so is to copy-and-pasting the font family name to both family name text boxes.  It's quite annoying.

If we have some UI, such as a checkbox "use the same font family to Western and Asian," makes us (Asian people) happy.

Steps to Reproduce:
1. Open a particular LibO component (for example, Writer)
2. Format > Character > Font to invoke the font selection dialog


Actual Results:
We have separate font-family text boxes for Western and Asian, so we have to fill in it the same name if we preferred to use the same font for both.  The easiest way is copying and pasting.

Expected Results:
We have some UI widgets to use the same font family for Western and Asian.


Reproducible: Always


User Profile Reset: No



Additional Info:
I'm not sure CTL people have the same requirement, so I file it as an Asian (CJK) problem.  But they may have the same annoyance.
Comment 1 Kevin Suo 2022-01-24 10:00:51 UTC
It makes sense for me, but for a new document the default font is:
en: Liberation Serif
CJK: Source Han Serif SC
Complex: Mangal

then which one should we use? I assume it should be the following in this case:
en: Source Han Serif SC
CJK: Source Han Serif SC
Complex: Mangal
Comment 2 Heiko Tietze 2022-01-24 10:02:44 UTC
To my understanding all text uses the same font. Like for Western.
Comment 3 Kevin Suo 2022-01-24 10:04:39 UTC
(In reply to Heiko Tietze from comment #2)
I think that is not possible, as apparently Source Han Serif SC does not cover those Complex characters.
Comment 4 Mike Kaganski 2022-01-24 10:59:08 UTC
See also bug 104318.
Comment 5 Heiko Tietze 2022-01-24 11:01:36 UTC
From IRC:

[11:39] <cloph> htietze: the request is to have a checkbox "use same font" to not have to select it both times, changing the default fonts is out of scope really/should be treated separately.
[11:42] <htietze> Having the same font can be achieved easily by not enabling CJK.
[11:42] <mikekaganski> htietze: when you do not enable CJK, you hide some controls, not enable "same font"
[11:43] <cloph> that is not a solution though. you will want to configure the advanced text layout stuff...
[11:43] <htietze> But in this case you always use the font set-up with Western, don't you?
[11:43] <mikekaganski> htietze: no
[11:44] <mikekaganski> the style/formatting still has the respective CJK settings, and they are (mostly) used the same way, just hidden from the UI (and the "almost" is a bug IMO)
[11:55] <htietze> mikekaganski: And what I understand from the request is to exactly not just hide controls but always use the same font.
Comment 6 Mike Kaganski 2022-01-24 11:07:39 UTC
I don't think it's a reasonable request at this time. As mentioned in comment 0, it's only viable using very few specific fonts; as mentioned in comment 3, it will still be only possible for a subset of the languages. Using styles, defining that two (three) fonts would be needed only a few times - per style; using templates, the definition would only need to be performed once for the template. WF IMO (and looking forward to see some more radical change).
Comment 7 Hossein 2022-01-24 12:02:39 UTC
I also think that this option is unnecessary, because it is about what font you prefer/need and this is something completely subjective and also dependent on the actual fonts. 

For the CTL, we always need to set the font for western and CTL separately. In the formatting instructions, we are always said to use some specific font family for western, and another for CTL.

I've seen few cases that people use the same font family for CTL and western, and that is almost always when they didn't have a good CTL font installed.

For a comparison, I've looked at MS Word, and there was not such an option to use the same font family for CTL and CJK as it is used for western. Although the font size and style was shared among CJK and western.

I should add that this is not a repetitive task, and I agree with Mike that using styles is a better idea compared to setting fonts manually for each part of text.
Comment 8 Hossein 2022-01-24 12:11:18 UTC
Let me add that there can be a written text in the "Font" box, showing ("Use Asian text font") in Microsoft Word. But, then again one have to use copy and paste to use it.
Comment 9 Hossein 2022-01-24 12:20:54 UTC
Created attachment 177745 [details]
MS font selection dialog

This is the font selection dialog from MS Word 2007. Both "Latin text > Asian text font" and "Complex scripts > Font" are enabled.
Comment 10 Hossein 2022-01-24 12:45:43 UTC
Created attachment 177750 [details]
All scripts option in MS Word

When modifying the font settings for a style in MS Word, there is an option to use the same settings for all scripts.
Comment 11 Heiko Tietze 2022-02-14 11:07:42 UTC
Summarizing the comments this request is a WONTFIX.
Comment 12 Naruhiko Ogasawara 2022-02-14 23:22:48 UTC
Thanks for the worth discussion.  And I found my annoyance is from some issues related to font only in macOS, then I will file these, and I agree with the decision.
Comment 13 JO3EMC 2022-02-17 04:08:42 UTC
Created attachment 178331 [details]
Test Layout for Choice of using same font

It's a regrettable that the issue will be closed before I can participate in the discussion.

I think it would be convenient if we could select an option instead of making it common all the time.
I imagined a UI like an attachment. The first one uses a check box, and the second one uses a combo box like MS Word.

It seems that it has been talked about in another issue in the past, so I hope that the discussion will resume somewhere.
Comment 14 JO3EMC 2022-02-17 04:31:34 UTC
Created attachment 178332 [details]
Test Layout for Choice of using same font (rev1)

I'm sorry.
I made a mistake, so uploaded the revised version.
Comment 15 Eyal Rozenberg 2022-03-30 08:44:37 UTC
As an RTL language user, I'll say I also sometimes want to set the Western and RTL language fonts to the same one. But - it's not frequent enough to necessitate its own UI. Plus, if anything, I might want to set a different font for Hebrew and for Arabic or Farsi, and that's not supported at all...