Bug 147034 - Match Excel possibilities to specify permissions on protecting a sheet
Summary: Match Excel possibilities to specify permissions on protecting a sheet
Status: RESOLVED DUPLICATE of bug 57091
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.5.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL: https://ask.libreoffice.org/t/protect...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-28 09:33 UTC by Peter Johannes
Modified: 2022-01-28 10:23 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Johannes 2022-01-28 09:33:59 UTC
Description:
I ran into an issue while collaborating on a spreadsheet:
On protecting a sheet in Excel, permission can be given on each of these points:

    Select locked cells
    Select unlocked cells
    format cells
    format columns
    format rows
    insert columns
    insert rows
    insert hyperlinks
    delete columns
    delete rows
    sort
    use autofilter
    use pivot table reports
    edit objects
    edit scenarios

in LibreOffice-calc, only

    Select locked cells
    Select unlocked cells
    insert columns
    insert rows
    delete columns
    delete rows
are possible

Particularly the lack of "sort" and "autofilter" are difficult in my case

Steps to Reproduce:
1.import an xl spreadsheet with a protected sheet with sort and autofilter permission
2.unlock sheet
3.edit something
4.relock sheet
5. save in xls format


Actual Results:
opening the file in excel does not allow you to filter or sort without unlocking

Expected Results:
being able to sort or filter the sheet without unlocking in xl


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.5.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.2.5-0ubuntu0.21.10.1
Calc: threaded

I AM NOT SURE ABOUT THE SEVERITY: IT IS INDEED NORMAL IF COMPATIBILITY WITH EXCEL IS EXPECTED, OTHERWISE IT'S A FEATURE REQUEST

Also, I think it is also present in much earlier versions but I have no means to determine exactly which, a similar bug was reported in 2006 on AOO: https://bz.apache.org/ooo/show_bug.cgi?id=71468
Comment 1 Timur 2022-01-28 10:23:48 UTC
Filed in 2012.Please search before reporting. Still needs a volunteer.

*** This bug has been marked as a duplicate of bug 57091 ***