Bug 147064 - Color-Picker-Widget: The rightmost colors can not be selected due to scroll bar position
Summary: Color-Picker-Widget: The rightmost colors can not be selected due to scroll b...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.5.2 release
Hardware: All Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Color-Picker-Widget GTK3
  Show dependency treegraph
 
Reported: 2022-01-29 20:24 UTC by jose.velez
Modified: 2022-02-14 12:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Image of the colors under the scrollbar (18.58 KB, image/png)
2022-01-29 20:24 UTC, jose.velez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jose.velez 2022-01-29 20:24:12 UTC
Description:
Using libreoffice and GTK3 pluging you can not select some colors with the mouse because they are under the left scroll bar.

Steps to Reproduce:
1. Open any color palette in the sidebar or in the toolbar.
2. You can't select colors of the rightmost column of the palette using the mouse because the scroll bar overlaps the column of colors.

Actual Results:
You can't select colors using the mouse.

Expected Results:
You can select colors using the mouse.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Tested in Kubuntu and Neon with GTK3 pluging.
Comment 1 jose.velez 2022-01-29 20:24:49 UTC
Created attachment 177907 [details]
Image of the colors under the scrollbar
Comment 2 raal 2022-02-13 08:18:48 UTC
Tested Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 1c0aa970650ffc7c749e0b5ea655ebb2d137c8ae
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded Jumbo

The slider is over the right column of colors, but when I move mouse left, the slider hide. Then I can choose the color.
Comment 3 Dieter 2022-02-13 11:45:38 UTC
(In reply to raal from comment #2)
> The slider is over the right column of colors, but when I move mouse left,
> the slider hide. Then I can choose the color.

So you can confirm bug, but it looks like a minor bug
=> NEW
Comment 4 raal 2022-02-13 11:53:13 UTC
(In reply to Dieter from comment #3)
> (In reply to raal from comment #2)
> > The slider is over the right column of colors, but when I move mouse left,
> > the slider hide. Then I can choose the color.
> 
> So you can confirm bug, but it looks like a minor bug
> => NEW

I'm not sure if it's a bug or standard behavior.
Comment 5 Dieter 2022-02-13 12:24:11 UTC
(In reply to raal from comment #4)
> I'm not sure if it's a bug or standard behavior.

I think it' a bug, because it looks normal in Windows.
Comment 6 jose.velez 2022-02-14 08:57:34 UTC
(In reply to raal from comment #2)
> Tested Version: 7.4.0.0.alpha0+ / LibreOffice Community
> Build ID: 1c0aa970650ffc7c749e0b5ea655ebb2d137c8ae
> CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
> Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
> Calc: threaded Jumbo
> 
> The slider is over the right column of colors, but when I move mouse left,
> the slider hide. Then I can choose the color.

But I can't select any color of the last right column. If I move the mouse left, then I can choose a color of the penultimate column, but not from the last right column.
Comment 7 Caolán McNamara 2022-02-14 12:42:22 UTC
The overlay scrollbar should disappear if you move your mouse to the left and then you can move your mouse to the right over the last column when the overlay scrollbar is gone.

This is controlled by gtk's "gtk-overlay-scrolling". See https://www.linuxuprising.com/2019/09/how-to-disable-gnomes-overlay.html if you hate it and want to disable it.