Bug 147166 - Changing text color of list item changes vertical spacing
Summary: Changing text color of list item changes vertical spacing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.8.1 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.4.0 target:7.3.2 target:7.2.7
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2022-02-04 00:49 UTC by Gerald Pfeifer
Modified: 2022-02-21 12:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample slides in PPTX format (and note removing the first makes the problem on the second go away) (24.42 KB, application/vnd.ms-powerpoint)
2022-02-04 00:49 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2022-02-04 00:49:45 UTC
Created attachment 178030 [details]
Sample slides in PPTX format (and note removing the first makes the problem on the second go away)

How to repeat:

 1. Open document.
 2. Navigate to slide 2.
 3. Highlight 


Seen with 

Version: 7.1.8.0.0+ / LibreOffice Community
Build ID: 4784990eda6098f0408276b4d424e81382a50460
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-1, Time: 2021-10-15_11:37:03

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 5c138ac6a8334825ef171ac6291b66b277eb4288
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US

Not see with

Version: 7.0.7.0.0+
Build ID: 54e9dd41dc9dd45af12c9346199f601ea4a5994d
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-0, Time: 2021-05-07_08:22:18


Bug #147121 looks related, also that one regressed between 7.1 and 7.2,
not 7.0 and 7.1 as this one, so likely a different root cause.

Also - important clue! - the problem goes away if I delete the first 
slide. Maybe some variables not properly initialized?
Comment 1 Gerald Pfeifer 2022-02-04 01:01:58 UTC
Bug #147121 looks related, alas/although that one regressed between
7.1 and 7.2, not 7.0 and 7.1 as this one, so likely a different cause.
Comment 2 Ezinne 2022-02-10 22:04:29 UTC
Please can you give more details on what the third step, Highlight means?
Comment 3 Gerald Pfeifer 2022-02-10 22:41:22 UTC
(In reply to Ezinne from comment #2)
> Please can you give more details on what the third step, Highlight means?

Sorry, those instructions got garbled somehow while I was submitting.
Let me try again.

How to repeat:

 1. Open document.
 2. Navigate to slide 2.
 3. Select the text "Open Source cannot be canceled.",
    for example by double clicking somewhere into that line.
 4. Select a different font color.
 5. Observe how the vertical spacing towards the list item above
    increases.
Comment 4 Gabor Kelemen (allotropia) 2022-02-18 13:17:35 UTC
Confirming in
Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 1c0aa970650ffc7c749e0b5ea655ebb2d137c8ae
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: hu-HU (hu_HU.UTF-8); UI: en-US
Calc: threaded

Deleting the first slide does not stop the problem for me.

Bibisected in 7.1-linux to 

https://git.libreoffice.org/core/+/fb8973f31f111229be5184f4e4223e963ced2c7b

author	Caolán McNamara <caolanm@redhat.com>	Sat Oct 10 19:21:38 2020 +0100
committer	Caolán McNamara <caolanm@redhat.com>	Sat Oct 10 22:19:25 2020 +0200

ofz#23492 the only user of this ctor throws away the original of the clone

Adding CC to: Caolán McNamara
Comment 5 Commit Notification 2022-02-19 21:41:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/19613544fcba9e08d0d9f24cbd976ed12431d4b2

tdf#147166 EditTextObjectImpl copy ctor doesn't exactly copy EditTextObjectImpl

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2022-02-19 21:43:07 UTC
fixed in trunk, backport to 7-3 and 7-2 in gerrit
Comment 7 Gerald Pfeifer 2022-02-20 09:07:28 UTC
Thank you, Caolán!

Happy to verify this as fixed with today's daily build:

  Version: 7.4.0.0.alpha0+ / LibreOffice Community
  Build ID: b965efc0ab5d6996417c92b5588e9d1ff79e0572
  CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: gtk3
  Locale: en-US (en_US.UTF-8); UI: en-US


Is there any chance for a testcase to avoid regressions?
Comment 8 Commit Notification 2022-02-21 12:24:10 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/6842e0f786c7f3fc859bd7337427d7a4b37befed

tdf#147166 EditTextObjectImpl copy ctor doesn't exactly copy EditTextObjectImpl

It will be available in 7.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2022-02-21 12:25:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/88d66dc654c54cdbf4d429fd4e616eda5a78a3a4

tdf#147166 EditTextObjectImpl copy ctor doesn't exactly copy EditTextObjectImpl

It will be available in 7.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.