Bug 147190 - FILEOPEN XML2003 Date formatting of cells is missing
Summary: FILEOPEN XML2003 Date formatting of cells is missing
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: All All
: medium normal
Assignee: Kohei Yoshida
Keywords: bibisected, bisected, regression
Depends on:
Blocks: MSO-XML2003
  Show dependency treegraph
Reported: 2022-02-04 13:03 UTC by Gabor Kelemen (allotropia)
Modified: 2023-09-28 23:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

The example file in Excel 2013 and Calc master (121.93 KB, image/png)
2022-02-04 13:03 UTC, Gabor Kelemen (allotropia)

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2022-02-04 13:03:08 UTC
Created attachment 178057 [details]
The example file in Excel 2013 and Calc master

This is split off from bug 118227

When attachment 153834 [details] is opened in Calc, the date formatted contents of cells D3:D4 appear as integer numbers instead of dates formatted like: "1999.04-01"

Version: (x64) / LibreOffice Community
Build ID: bb7873cebd191143e2c0bcf944c8c777be5439dc
CPU threads: 13; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: threaded
Comment 1 raal 2022-02-04 19:58:07 UTC
Confirm with Version: / LibreOffice Community
Build ID: 0b397d8ef0a2615e8e6202804ca2f6cb58436fa5
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded Jumbo

works in Version (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 2 raal 2022-02-11 22:07:18 UTC
It worked in version 4, then in version 6 import didn't worked at all - imported sheet was empty. In bibisect repo bibisect-linux-64-6.4 import started to work again, but without date formatting with this commit: 99c6c75d1436183da6a3b025530dc14d330f7a43 is the first bad commit
commit 99c6c75d1436183da6a3b025530dc14d330f7a43
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Aug 15 06:16:23 2019 +0200

    source 56ffe3c0a1261cd98a3d42b8b08d5f8eb013ead4

   Switch mdds to 1.5.0 and liborcus to 0.15.0.
Adding CC to: Kohei Yoshida
Comment 3 Kohei Yoshida 2023-09-28 23:54:21 UTC
The latest liborcus version 0.19.0 should fix this problem.