Bug 147224 - LibreOffice without the Filter function
Summary: LibreOffice without the Filter function
Status: RESOLVED DUPLICATE of bug 126573
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-06 00:18 UTC by David Leal
Modified: 2022-05-23 03:40 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Leal 2022-02-06 00:18:11 UTC
Does the new version bring the Filter function? It will be interesting to add it for the possibilities. I leave a demo video

https://www.youtube.com/watch?v=uBUr9YdaXCw
Comment 1 David Leal 2022-02-06 01:01:36 UTC
The idea is not to use macros. There's no turning back, the Filter function is ideal for making the dropBox searchable! I did the following experiment just now: I opened excel from outlook.com and made a small table using the filter function. Then I downloaded this file to my PC and opened it with version 7.2.5 of Calc, to see if there is any similar function. The return was: =_xlfn._xlws.filter(A2:A9;B2:B9="A";"Not Found") The same return appeared in OnlyOffice with this difference =_XLWS.FILTER(A2:A9;B2:B9= "A";"Not Found"); with the difference that OnlyOffice was the only one capable of putting it into action! Calc was not able to! Now imagine you have an Excel database using this function. You will not have that file working in Calc. This function must be implemented in Calc. It opens up many avenues for advanced research.
Comment 2 Mike Kaganski 2022-05-22 09:06:24 UTC

*** This bug has been marked as a duplicate of bug 126573 ***