Bug 147366 - Documentation for v7.2 states LOG() is natural log. Trying LOG(10) shows it isn't
Summary: Documentation for v7.2 states LOG() is natural log. Trying LOG(10) shows it ...
Status: RESOLVED DUPLICATE of bug 131382
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-11 08:51 UTC by combes
Modified: 2022-02-11 10:55 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description combes 2022-02-11 08:51:52 UTC
As described at https://help.libreoffice.org/7.2/en-GB/text/sbasic/shared/03080202.html?&DbPAR=WRITER&System=WIN the LOG(x) function is natural log (i.e. base e)

In version 7.2.5.2 on Windows (the only version tested) LOG(10) returns 1.  i.e. this is in fact LOG10(x)

Sample other tested values are also LOG10()
Comment 1 Mike Kaganski 2022-02-11 09:33:38 UTC
Are you confusing Basic function Log (which help page you are citing) with spreadsheet function LOG [1]? You didn't mention how exactly did you test it.

[1] https://help.libreoffice.org/7.2/en-GB/text/scalc/01/04060106.html?DbPAR=CALC#bm_id3109813
Comment 2 combes 2022-02-11 10:28:00 UTC
(In reply to combes from comment #0)
> As described at
> https://help.libreoffice.org/7.2/en-GB/text/sbasic/shared/03080202.
> html?&DbPAR=WRITER&System=WIN the LOG(x) function is natural log (i.e. base
> e)
> 
> In version 7.2.5.2 on Windows (the only version tested) LOG(10) returns 1. 
> i.e. this is in fact LOG10(x)
> 
> Sample other tested values are also LOG10()

Yes, looks like I am confusing different functions in different places - if I follow LOG(x) does one thing in one part and one thing in another place?  either Log10 or Ln

I tested by typing LOG(10) and LOG(cell ref) in a cell

This does seem to be something that could be much clearer in the documentation.  At least a warning that the same named function does different things in different parts of the suite
Comment 3 Mike Kaganski 2022-02-11 10:54:34 UTC
(In reply to combes from comment #2)
>
> if I follow LOG(x) does one thing in one part and one thing in another place? 
> either Log10 or Ln

Yes, LOG in spreadsheet is very different from Log in Basic macro.

> This does seem to be something that could be much clearer in the
> documentation.  At least a warning that the same named function does
> different things in different parts of the suite

Which is why I added bug 131382 to See Also for your information.
Comment 4 Mike Kaganski 2022-02-11 10:55:41 UTC

*** This bug has been marked as a duplicate of bug 131382 ***