Bug 147480 - CR/LF disappear when copy/paste a cell that have multiple lines
Summary: CR/LF disappear when copy/paste a cell that have multiple lines
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Files-Linked
  Show dependency treegraph
 
Reported: 2022-02-17 06:13 UTC by titanemdg
Modified: 2022-03-12 09:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
These files reproduce the missing of CR/LF (13.96 KB, application/x-zip-compressed)
2022-02-17 06:14 UTC, titanemdg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description titanemdg 2022-02-17 06:13:17 UTC
Description:
I copied a cell from calc that have multiple line containing CR/LF symbol to a Writer document. The link is DDE. All CR/LF disappear and replaced by a spaces.

Steps to Reproduce:
1. In calc, create a cell with multiple line separated by CR/LF
2. Copy the cell and paste it in a Writer document as DDE link
3. Check in the Writer document: multiple line becomes one line. All CR/LF are replaced by spaces.

Actual Results:
SPACE replaces CR/LF

Expected Results:
Reproduce the CR/LF


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 titanemdg 2022-02-17 06:14:16 UTC
Created attachment 178334 [details]
These files reproduce the missing of CR/LF
Comment 2 Dieter 2022-03-03 18:29:24 UTC
Thank you for reporting the bug. It seems you're using an old version of LibreOffice. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 3 titanemdg 2022-03-11 08:34:07 UTC
I set to 'Unconfirmed' because in version 7.3.1 the bug is still there.

Version: 7.3.1.3 (x64) / LibreOffice Community
Build ID: a69ca51ded25f3eefd52d7bf9a5fad8c90b87951
CPU threads: 2; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win
Locale: fr-FR (fr_FR); UI: en-US
Calc: threaded
Comment 4 raal 2022-03-12 09:03:43 UTC
I can confirm with Version: 7.2.5.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: cs-CZ
Ubuntu package version: 1:7.2.5-0ubuntu0.21.10.1
Calc: threaded
and Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

There is another bug, preventing test in dev version 7.4.