Bug 147761 - Record macro, does not record "sort"
Summary: Record macro, does not record "sort"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.5.2 release
Hardware: All All
: medium normal
Assignee: Szymon Kłos
URL:
Whiteboard: target:7.4.0 target:7.3.3
Keywords: bibisected, bisected, regression
: 145622 (view as bug list)
Depends on:
Blocks: Macro-Recording
  Show dependency treegraph
 
Reported: 2022-03-04 10:15 UTC by Mark Mclean
Modified: 2022-03-28 10:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Try to record a macro to sort a column. (22.50 KB, application/vnd.oasis.opendocument.spreadsheet)
2022-03-04 10:21 UTC, Mark Mclean
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Mclean 2022-03-04 10:15:27 UTC
Description:
I run "record macro". When I use sort, it does not record it as it did a year ago.

Steps to Reproduce:
1.record macro, use "sort"
2.run macro,
3.does not sort

Actual Results:
1.record macro, use "sort"
2.run macro,
3.does not sort

Expected Results:
to copy what I did in sort. As it worked years before. and as I have macros in other files that do work with sort.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 Mark Mclean 2022-03-04 10:21:29 UTC
Created attachment 178653 [details]
Try to record a macro to sort a column.
Comment 2 Mark Mclean 2022-03-04 10:22:29 UTC
Record a macro while sorting a column. then run that recorded macro.
Comment 3 LeroyG 2022-03-04 21:18:33 UTC
There are only one instruction to sort and is preceded with rem:

"rem dispatcher.executeDispatch(document, ".uno:DataSort", "", 0, Array())"

Are you invoking the sort fuction with the mouse or with the keyboard?
Comment 4 Mark Mclean 2022-03-04 22:38:46 UTC
I only use "Run macro". I do not write them. I have recorded the same a year ago, it still works good. Thanks for your time. Not a must to fix but I thought it should be know
Comment 5 QA Administrators 2022-03-05 03:34:42 UTC Comment hidden (obsolete)
Comment 6 Mark Mclean 2022-03-05 10:18:02 UTC
keyboard
Comment 7 Mark Mclean 2022-03-05 10:18:41 UTC
Not key board but touchpad
Comment 8 raal 2022-03-05 11:30:24 UTC
Confirm with Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: c97a3592c78ce276a353f95ce68c70a8a39174a0
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded Jumbo

works in Version: 6.3.0.0.alpha1+
Build ID: c98b1f1cd43b3e109bcaf6324ef2d1f449b34099
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: gtk3; 
Locale: cs-CZ (cs_CZ.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 raal 2022-03-06 07:41:58 UTC
This seems to have begun at the below commit.
Adding Cc: to Szymon Kłos; Could you possibly take a look at this one?
Thanks
linux-64-7.1$ 72426d44584b2277ddf78d3e438f4fd8c989d9d4 is the first bad commit
commit 72426d44584b2277ddf78d3e438f4fd8c989d9d4
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Jul 28 17:57:28 2020 +0200

    source sha:70b81e74d2a14308e1897d840c681404225d328a

https://git.libreoffice.org/core/+/70b81e74d2a14308e1897d840c681404225d328a
  Make Sort dialog async
Comment 10 Szymon Kłos 2022-03-07 08:49:04 UTC
I will try to check that this week
Comment 11 Commit Notification 2022-03-15 07:19:35 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/eca978841816f833616b4c2334e65aa976a9fb61

tdf#147761 record sort command in macros

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Timur 2022-03-21 14:03:43 UTC
*** Bug 145622 has been marked as a duplicate of this bug. ***
Comment 13 Timur 2022-03-21 14:05:06 UTC
Thanks Szymon. Please backport.
Comment 14 Timur 2022-03-21 14:06:32 UTC
I see backport for 7.3 but 7.2 would also be nice if possible.
Comment 15 Commit Notification 2022-03-28 10:00:49 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/db61167cdfdde69d115338be7d50447e81b43616

tdf#147761 record sort command in macros

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.