Bug 147809 - Updating a paragraph style's associated list style has no effect on other paragraphs with the style
Summary: Updating a paragraph style's associated list style has no effect on other par...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Styles
  Show dependency treegraph
 
Reported: 2022-03-06 17:39 UTC by Eyal Rozenberg
Modified: 2022-04-19 22:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document for reproducing the bug (9.77 KB, application/vnd.oasis.opendocument.text)
2022-03-25 15:15 UTC, Eyal Rozenberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2022-03-06 17:39:27 UTC
I have a certain custom list style in my document, which currently applies numbering, and I want to have it be a bulleted non-numbered list style with a certain bullet (specifically, an en-dash). However, when I:

1. Select a paragraph.
2. Apply the style.
3. Make the paragraph be bulleted with my desired bullet.
4. Perform "Updated Selected Style" using the Styles side-bar.

Nothing seems to change, i.e. other paragraphs with the custom style do not become bulleted, and when I apply this style to another paragraph (which did not have it before), I get the numbering, not the bullets.

I'm not sure if the problem is with the feature itself or with the sidebar menubutton I use for the update.

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: fb9270b238cba4f36e595c5d7f4d85f6f3f18e1c
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-IL (en_IL); UI: en-US
Comment 1 Dieter 2022-03-23 07:32:04 UTC
I can't confirm with

Version: 7.3.2.1 (x64) / LibreOffice Community
Build ID: 0b2e59a88b7e225b655db87910f97dca7aef27aa
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Steps:
1. Select a paragraph and apply a paragraph style
2. Apply a list style to that paragraph (for example "Bullet -")
3. Perform "Updated Selected Style" using the Styles side-bar

If you have a look at "Outline & List" tab of paragraph style you see, that a list style is needed.

Does this solve your problem? => NEEDINFO
Comment 2 Eyal Rozenberg 2022-03-25 15:15:04 UTC
Created attachment 179105 [details]
Document for reproducing the bug

Here are reproduction instructions, without even using a custom list style, just a custom paragraph style:

1.
1.1 Type in two paragraphs, with text "first" and "second" respectively (and type Enter after the end of each paragraph)
1.2 Create a new style based on the default paragraph style, named foo
1.3 Apply style "foo" to the first paragraph
1.4 Apply numbering style "Numbering 123" to the first paragraph
1.5 In the Styles Sidebar, switch to paragraph styles, right-click "foo" and from the top-right menubutton choose "Updated Selected Style"
1.6 Apply style foo to the second paragraph

(or alternatively: 
1. Open 147809.odt
)

2. Place cursor on one of the foo paragraphs
3. On the Styles Sidebar, choose List Styles
4. Apply the "Bullet -" style
5. In the Styles Sidebar, switch to paragraph styles, right-click "foo" and from the top-right menubutton choose "Updated Selected Style"

Expected results:
After step 1.5, the paragraphs begin with "1." and "2." respectively.
After step 5, both paragraphs have an en-dash-like bullet.

Actual result:
After step 1.5, the paragraphs begin with "1." and "2." respectively.
After step 5, only the paragraph chosen in step (2.) now exhibits an en-dash-like bullet, the other one is still preceded by a number.
Comment 3 Dieter 2022-03-25 15:24:37 UTC
(In reply to Eyal Rozenberg from comment #2)
> Expected results:
> After step 1.5, the paragraphs begin with "1." and "2." respectively.
> After step 5, both paragraphs have an en-dash-like bullet.

Yes, and this is my result.

After step 4, please open Format -> Paragraph -> Outline & List
List Stle "Bullet -" is the applied list style. Do you get the same result?
Comment 4 Eyal Rozenberg 2022-03-25 15:57:34 UTC
(In reply to Dieter from comment #3)
> (In reply to Eyal Rozenberg from comment #2)
> > Expected results:
> > After step 1.5, the paragraphs begin with "1." and "2." respectively.
> > After step 5, both paragraphs have an en-dash-like bullet.
> 
> Yes, and this is my result.
> 
> After step 4, please open Format -> Paragraph -> Outline & List
> List St[y]le "Bullet -" is the applied list style. Do you get the same result?

After step 4,

* Format -> Paragraph -> Outline & List while in the second paragraph - "Bullet -" is the applied list style.
* Format -> Paragraph -> Outline & List while in the first paragraph - "Numbering 123" is the applied list style.
* Right-click -> Outline & List on the "foo" style - "Numbering 123" is the applied list style.
Comment 5 Dieter 2022-03-25 16:14:29 UTC
(In reply to Eyal Rozenberg from comment #4)
> After step 4,
> 
> * Format -> Paragraph -> Outline & List while in the second paragraph -
> "Bullet -" is the applied list style.
> * Format -> Paragraph -> Outline & List while in the first paragraph -
> "Numbering 123" is the applied list style.
> * Right-click -> Outline & List on the "foo" style - "Numbering 123" is the
> applied list style.

Correct, so I don't understand, why "Update Selected Style" doesn't work for you, if cursor is in second paragraph.
Comment 6 Eyal Rozenberg 2022-03-25 17:02:13 UTC
(In reply to Dieter from comment #5)
> Correct, so I don't understand, why "Update Selected Style" doesn't work for
> you, if cursor is in second paragraph.

I don't know either... it just doesn't work. Maybe it's something with the nightly I'm using? Shall I try to run it from a terminal and see if I get some interesting output?
Comment 7 Dieter 2022-03-25 17:04:58 UTC
(In reply to Eyal Rozenberg from comment #6)
> Shall I try to run it from a terminal and see if I get
> some interesting output?

Don't know, sorry.
Comment 8 Indu 2022-04-05 22:31:17 UTC
hello!
I performed the steps with and without "open147809.odt" and could not reproduce the bug.

May be this was a one off and should be closed.
Comment 9 Eyal Rozenberg 2022-04-19 22:01:36 UTC
Can't reproduce with a more recent nightly -> WFM.