Bug 147866 - FILEOPEN: Hang at import time (gtk3)
Summary: FILEOPEN: Hang at import time (gtk3)
Status: RESOLVED DUPLICATE of bug 38575
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2022-03-09 09:47 UTC by Xisco Faulí
Modified: 2022-03-09 11:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2022-03-09 09:47:03 UTC
Steps to reproduce:
1. Open attachment 48294 [details] from bug 38575

-> LibreOffice hangs.

Reproduced in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: b461ada70158de5cd2e96a54147c8e46ee1ca4ac
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: es-ES (es_ES.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2022-03-09 09:49:02 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ce5e41ab99af350ca8f4b9fef3017d53f3526f83

author	Caolán McNamara <caolanm@redhat.com>	2020-10-25 15:14:56 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2020-10-25 22:02:17 +0100
commit ce5e41ab99af350ca8f4b9fef3017d53f3526f83 (patch)
tree 98c7cb352e0e0c4a103049c5b1f72e31197e3e29
parent 41df2d06cc13a1c60a4ea9671535afb8bd55b344 (diff)
Related: tdf#137620 use existing SalEvent::SurroundingTextRequest

Bisected with: bibisect-linux64-7.1

Adding Cc: to Caolán McNamara
Comment 2 Caolán McNamara 2022-03-09 11:00:09 UTC
if you load in gen, and then press the "end" key after it has loaded then that is basically the same operation that the "SurroundingTextRequest" does and I see that also hangs so that's the underlying problem.

I wonder if that hang on pressing end under gen is bisectable ?
Comment 3 Xisco Faulí 2022-03-09 11:21:31 UTC
(In reply to Caolán McNamara from comment #2)
> if you load in gen, and then press the "end" key after it has loaded then
> that is basically the same operation that the "SurroundingTextRequest" does
> and I see that also hangs so that's the underlying problem.
> 
> I wonder if that hang on pressing end under gen is bisectable ?

oh, then I believe we are just reproducing bug 38575. Thanks for the clarification.
Closing as duplicated

*** This bug has been marked as a duplicate of bug 38575 ***