Bug 147928 - Crash when inserting comment and undoing in Writer (gtk3 only)
Summary: Crash when inserting comment and undoing in Writer (gtk3 only)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.4.0 target:7.3.2
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2022-03-11 20:12 UTC by Julien Nabet
Modified: 2022-08-16 08:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt with debug symbols (5.06 KB, text/plain)
2022-03-11 20:12 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2022-03-11 20:12:52 UTC
Created attachment 178825 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I got a crash after this:
- launch Writer on a brand new file
- Menu Insert then Comment
=> A blank comment appears
- Ctrl-Z to undo
=> crash.
Comment 1 Julien Nabet 2022-03-11 20:14:44 UTC
I've got the crash only with gtk3 rendering, not with kf5 or gen rendering.
Comment 2 Julien Nabet 2022-03-11 20:15:44 UTC
Caolán: since it seems gtk3 specific, thought you might be interested in this one.
Comment 3 Caolán McNamara 2022-03-12 20:22:35 UTC
I can't reproduce normally, but I can see the problem on running under valgrind
Comment 4 Caolán McNamara 2022-03-12 20:23:06 UTC
I think its a generic problem that happens to crash for you with gtk3
Comment 5 Caolán McNamara 2022-03-13 10:27:48 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e54ac357ee669cfc7cb5c68eca4ddce27824ae9a

tdf#147929 "undo" may delete the current SwAnnotationShell

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2022-03-13 10:28:10 UTC
backport to 7-3 in gerrit with the right bug id used in the commit unlike this case
Comment 7 Commit Notification 2022-03-13 11:50:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/15fb24db540dc29883346d7e8e37d96e4fe8dfb1

tdf#147928 "undo" may delete the current SwAnnotationShell

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2022-03-23 10:02:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-3-2":

https://git.libreoffice.org/core/commit/3a6c7271b19ac1c38459ea4680f55a4fda7e3248

tdf#147928 "undo" may delete the current SwAnnotationShell

It will be available in 7.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.