Bug 148199 - Table paragraph styles not fully applied
Summary: Table paragraph styles not fully applied
Status: RESOLVED DUPLICATE of bug 104389
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables-Style
  Show dependency treegraph
 
Reported: 2022-03-26 09:14 UTC by Eyal Rozenberg
Modified: 2022-04-21 17:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2022-03-26 09:14:56 UTC
Reproduction instructions:

1. Create a new writer document.
2. Type in some text on the first line: "Hello"
2. Change the Table Contents style as follows:
   2.1 Make the Area solid-color-Yellow
   2.2 Make the font size a little smaller than the default (e.g. 10 instead of 12 pt)
3. Using the menus, Insert | Table
4. Choose a 2x2 table with a heading row
5. Type in "Hello" as before into a heading cell and into a non-heading cell

Expected results:
* Table cells are yellow
* Table cell text is smaller than the outside text
* First table row cells are centered
* First table row cell text is in boldface

Actual result:
* Table cells are yellow (... which is good)
* Table cell text is NOT smaller than the outside text
* First table row cells are NOT centered
* First table row cell text is NOT in boldface

If one re-applies the appropriate styles (Table Contents, Table Heading) to the table rows, they are applied properly.
Comment 1 Dieter 2022-04-10 09:48:04 UTC
I can't confirm with

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 040b3198fde3385e19e7380fdcabae84a0abac9d
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL
Comment 2 Eyal Rozenberg 2022-04-10 16:30:19 UTC
(In reply to Dieter from comment #1)

I forgot a very important point: Choosing the "Academic" table style. Can you try that?

Also, the table insertion is with "Table | Insert Table", nor "Insert | Table" as I had written.
Comment 3 Dieter 2022-04-11 06:45:18 UTC
Thank you for additional informations. I can reproduce the bug, but it looks like a duplicate of bug 145920

If you open style inspector after step 4 or 5, you see paragraph DF, that shouldn't be there.

So I mark it a sduplicate. Feel free to change it back with a short reasoning, if you disagree.

*** This bug has been marked as a duplicate of bug 145920 ***
Comment 4 Timur 2022-04-21 13:56:26 UTC
Eyal, there are many bugs on same, I don't know if you search before reporting.

*** This bug has been marked as a duplicate of bug 104389 ***
Comment 5 Eyal Rozenberg 2022-04-21 17:29:29 UTC
(In reply to Timur from comment #4)
> Eyal, there are many bugs on same, I don't know if you search before
> reporting.

Actually, it would be easier if the meta bugs were more accessible, e.g. in a searchable list of just the meta-bug names