Bug 148665 - CRASH in 7.4: importing DOCX document with diagram
Summary: CRASH in 7.4: importing DOCX document with diagram
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+ Master
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0
Keywords: bibisected, bisected, haveBacktrace, regression
: 148735 (view as bug list)
Depends on:
Blocks: OOXML-SmartArt
  Show dependency treegraph
 
Reported: 2022-04-19 08:52 UTC by Xisco Faulí
Modified: 2022-04-27 22:08 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
gdb bt (11.58 KB, text/plain)
2022-04-19 10:25 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2022-04-19 08:52:12 UTC
Steps to reproduce:
1. Open attachment 97672 [details] from bug 77716

-> Crash

reproduced in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 5e843d732d0a3f7613eaf003fc5c8dcc595b578d
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: es-ES (es_ES.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2022-04-19 08:53:00 UTC
Regression introduced by:

author	Armin Le Grand (Allotropia) <Armin.Le.Grand@me.com>	2022-04-04 16:57:08 +0200
committer	Armin Le Grand <Armin.Le.Grand@me.com>	2022-04-05 14:20:46 +0200
commit c79fa460fe6220051bbda2d3c0cb67fbf765e2ac (patch)
tree 1a3503ed30f8552f8ee1b7d8685433ceeb690ab1
parent a2bcac670ef0254d8b2e8632cfe07bb855b28d1c (diff)
Advanced Diagram support: Move Diagram Text information to svx

Bisected with: bibisect-linux64-7.4

Adding Cc: to Armin Le Grand
Comment 2 Julien Nabet 2022-04-19 10:25:08 UTC
Created attachment 179660 [details]
gdb bt

On pc Debian x86-64 with master sources updated today, I could reproduce this.

I attached bt with gdb console logs.
Comment 3 Xisco Faulí 2022-04-22 20:13:22 UTC
*** Bug 148735 has been marked as a duplicate of this bug. ***
Comment 4 Hossein 2022-04-24 05:42:01 UTC
I have submitted a patch to fix this:

tdf#148665 Fix crash while loading SmartArt graphics
https://gerrit.libreoffice.org/c/core/+/133341
Comment 5 Commit Notification 2022-04-27 10:17:46 UTC
Hossein committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/148f45253f75bc724804f3231a0b04b2d453e0c7

tdf#148665 Fix crash while loading SmartArt graphics

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2022-04-27 11:45:30 UTC
Hi Hossein,
I do confirm your patch fixes the issue. I've created a unittest in https://gerrit.libreoffice.org/c/core/+/133507
Meanwhile, I discovered another issue related to a missing test, which i've reported in bug 148818

Closing as VERIFIED FIXED
Comment 7 Commit Notification 2022-04-27 20:18:58 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/61a4b90dcdb953dd21a22a2f291ffd6be399ddd8

tdf#148665: sd_import_tests-smartart: Add unittest

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.