Bug 148841 - LibreOffice 7.2.5.1 Module Base, ODB - printing of a report fails
Summary: LibreOffice 7.2.5.1 Module Base, ODB - printing of a report fails
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.2.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-28 17:08 UTC by h8999
Modified: 2022-05-20 15:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Starting point ... (95.60 KB, image/png)
2022-04-28 17:11 UTC, h8999
Details
Error Message (140.08 KB, image/png)
2022-04-28 17:12 UTC, h8999
Details

Note You need to log in before you can comment on or make changes to this bug.
Description h8999 2022-04-28 17:08:29 UTC
Description:
Executing a report in an open odb crashes with errormessage. Document-Preview is OK. Same error with Version 7.3.0.3



Steps to Reproduce:
1.Doubleclick on *.odb
2.Select Reports
3.Execute

Actual Results:
The following Errormessage pops up:
[jni_uno bridge error] UNO calling Java method execute: non-UNO exception occurred: java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory
java stack trace:
java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory
	at org.pentaho.reporting.libraries.base.boot.AbstractBoot.<clinit>(AbstractBoot.java:55)
	at org.libreoffice.report.pentaho.PentahoReportEngine.<init>(PentahoReportEngine.java:34)
	at org.libreoffice.report.pentaho.SOReportJobFactory$_SOReportJobFactory.createReportJob(SOReportJobFactory.java:352)
	at org.libreoffice.report.pentaho.SOReportJobFactory$_SOReportJobFactory.execute(SOReportJobFactory.java:236)
Caused by: java.lang.ClassNotFoundException: org.apache.commons.logging.LogFactory
	at java.net.URLClassLoader.findClass(URLClassLoader.java:387)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:419)
	at java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:822)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:352)
	... 4 more
 /home/abuild/rpmbuild/BUILD/libreoffice-7.2.5.1/bridges/source/jni_uno/jni_uno2java.cxx:785


Expected Results:
OO Writer should come up to finish printing.


Reproducible: Always


User Profile Reset: No



Additional Info:
System:
Linux localhost.localdomain 5.3.18-150300.59.63-preempt #1 SMP PREEMPT Tue Apr 5 12:47:31 UTC 2022 (d77db66) x86_64 x86_64 x86_64 GNU/Linux

Packages installed:
libreoffice-7.2.5.1-150300.14.22.18.3.x86_64
libreoffice-base-7.2.5.1-150300.14.22.18.3.x86_64
libreoffice-branding-openSUSE-15.3.20210112-lp153.1.26.noarch
libreoffice-calc-7.2.5.1-150300.14.22.18.3.x86_64
libreoffice-draw-7.2.5.1-150300.14.22.18.3.x86_64
libreoffice-filters-optional-7.2.5.1-150300.14.22.18.3.x86_64
libreoffice-icon-themes-7.2.5.1-150300.14.22.18.3.noarch
libreoffice-impress-7.2.5.1-150300.14.22.18.3.x86_64
libreofficekit-7.2.5.1-150300.14.22.18.3.x86_64
libreoffice-l10n-de-7.2.5.1-150300.14.22.18.3.noarch
libreoffice-l10n-en-7.2.5.1-150300.14.22.18.3.noarch
libreoffice-mailmerge-7.2.5.1-150300.14.22.18.3.x86_64
libreoffice-math-7.2.5.1-150300.14.22.18.3.x86_64
libreoffice-pyuno-7.2.5.1-150300.14.22.18.3.x86_64
libreoffice-qt5-7.2.5.1-150300.14.22.18.3.x86_64
libreoffice-share-linker-1-3.3.1.noarch
libreoffice-writer-7.2.5.1-150300.14.22.18.3.x86_64
Comment 1 h8999 2022-04-28 17:11:17 UTC
Created attachment 179828 [details]
Starting point ...
Comment 2 h8999 2022-04-28 17:12:14 UTC
Created attachment 179829 [details]
Error Message
Comment 3 h8999 2022-04-28 17:25:08 UTC
Forgot to include Java Version:
openjdk 11.0.14.1 2022-02-08
OpenJDK Runtime Environment (build 11.0.14.1+1-suse-3.77.5-x8664)
OpenJDK 64-Bit Server VM (build 11.0.14.1+1-suse-3.77.5-x8664, mixed mode)
Comment 4 Robert Großkopf 2022-05-13 06:07:14 UTC
Which version of LO do you use? Reading the packages it seems to be the version of OpenSUSE. Try it with the packages original for LO. If you need help with installing original packages you could contact me directly.

I will get the same error with packages directly from OpenSUSE, but I don't use this version of LO. Have installed also different version of LO directly and this versions will show the reports.

I will set this to "NOTOURBUG"