Bug 149256 - Ship LibreOfficeKit headers and library files with the LibreOffice SDK community packages
Summary: Ship LibreOfficeKit headers and library files with the LibreOffice SDK commun...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: sdk (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:25.2.0
Keywords:
: 149249 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-05-24 07:36 UTC by Hossein
Modified: 2024-07-02 10:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hossein 2022-05-24 07:36:08 UTC
With LibreOfficeKit (LOK), it is possible to create C++ applications that can access LibreOffice functionality.

LibreOfficeKit module documentation:
https://docs.libreoffice.org/libreofficekit.html

As there are few dependencies for creating applications with LOK, it would be beneficial to have LibreOfficeKit headers and the library files shipped with the SDK. In this way, one can build LOK C++ apps without building LibreOffice, and just by installing SDK and build tools.

The headers and library files are available on Ubuntu and Debian packages, but the headers are not available through LibreOffice community packages. Please note that I have LibreOffice 7.3 + SDK installed on my Ubuntu system.

$ dpkg -S liblibreofficekitgtk.so
libobasis7.3-core: /opt/libreoffice7.3/program/liblibreofficekitgtk.so

$ dpkg -S LibreOfficeKit.h
dpkg-query: no path found matching pattern *LibreOfficeKit.h*

https://packages.ubuntu.com/jammy/amd64/libreofficekit-dev/filelist
https://packages.ubuntu.com/jammy/amd64/liblibreofficekitgtk/filelist

https://packages.debian.org/stretch/all/libreofficekit-dev/filelist
https://packages.debian.org/stretch/all/liblibreofficekitgtk/filelist

Neither the headers, nor the library files are available on LibreOffice community packages for Windows.
Comment 1 Xisco Faulí 2022-05-24 07:57:36 UTC
Maybe something to be discussed in the ESC meeting ?
Comment 2 Hossein 2022-07-08 20:16:42 UTC
(In reply to Xisco Faulí from comment #1)
> Maybe something to be discussed in the ESC meeting ?

Yes. This was discussed in the ESC call:

ESC meeting minutes: 2022-05-26
https://lists.freedesktop.org/archives/libreoffice/2022-May/088940.html

+ LibreOfficeKit question (Hossein)
   + the headers are not part of the binary packages
   + but Debian/Ubuntu packages it
     + sounds like a good idea to put the headers into the SDK (Caolan)
   + https://bugs.documentfoundation.org/show_bug.cgi?id=149256
     https://gerrit.libreoffice.org/c/core/+/134863
     + happy to help with packaging (Cloph)

As a result, I am setting the status as NEW.
Comment 3 Hossein 2023-01-17 09:48:21 UTC
*** Bug 149249 has been marked as a duplicate of this bug. ***
Comment 4 Hossein 2023-01-17 09:51:41 UTC
This part was in the duplicate report:

I think it would be better to ship both the headers and library files in the SDK or a separate package.

$ dpkg -L libobasis7.3-libreofficekit-data
/.
/opt
/opt/libreoffice7.3
/opt/libreoffice7.3/share
/opt/libreoffice7.3/share/libreofficekit
/opt/libreoffice7.3/share/libreofficekit/handle_image_end.png
/opt/libreoffice7.3/share/libreofficekit/handle_image_middle.png
/opt/libreoffice7.3/share/libreofficekit/handle_image_start.png

On Windows, both headers and library files are missing from an installation of LibreOffice + SDK.
Comment 5 Commit Notification 2024-06-23 17:57:46 UTC
Hossein committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1305edfbc27121d7fc8973ccafb92f76d5401ac1

tdf#149256 Ship LibreOfficeKit headers in packages

It will be available in 25.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2024-07-02 10:11:11 UTC
Hossein committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b7a5d0e5669863033156ef15190c9fd509c45fa3

tdf#149256 Ship LibreOfficeKit headers in packages

It will be available in 25.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.