Bug 149425 - EDITING: Business Cards Alt+Arrow behavior
Summary: EDITING: Business Cards Alt+Arrow behavior
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.3.2 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL: https://help.libreoffice.org/7.4/en-U...
Whiteboard:
Keywords:
Depends on:
Blocks: Labels-BusinessCards
  Show dependency treegraph
 
Reported: 2022-06-01 20:05 UTC by Pierre Fortin
Modified: 2022-06-09 07:54 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
dialog when creating new document (60.43 KB, image/png)
2022-06-01 20:05 UTC, Pierre Fortin
Details
New Document layout does not match dialog (166.76 KB, image/png)
2022-06-01 20:06 UTC, Pierre Fortin
Details
attempt to correct settings (147.58 KB, image/png)
2022-06-03 12:24 UTC, Pierre Fortin
Details
closer look at wrong document size (119.14 KB, image/png)
2022-06-03 12:42 UTC, Pierre Fortin
Details
BusinessCard -- image not synch'ed (36.14 KB, application/vnd.oasis.opendocument.text)
2022-06-03 18:17 UTC, Pierre Fortin
Details
Nothing selected (102.21 KB, image/png)
2022-06-08 15:32 UTC, Pierre Fortin
Details
Image selected (107.32 KB, image/png)
2022-06-08 15:35 UTC, Pierre Fortin
Details
Frame selected (98.77 KB, image/png)
2022-06-08 15:37 UTC, Pierre Fortin
Details
Selected text (110.37 KB, image/png)
2022-06-08 15:40 UTC, Pierre Fortin
Details
Frame 2 (97.48 KB, image/png)
2022-06-08 15:43 UTC, Pierre Fortin
Details
Text in frame 2 (108.66 KB, image/png)
2022-06-08 15:50 UTC, Pierre Fortin
Details
Business card file used for screenshots (52.09 KB, application/vnd.oasis.opendocument.text)
2022-06-08 15:51 UTC, Pierre Fortin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Fortin 2022-06-01 20:05:32 UTC
Created attachment 180529 [details]
dialog when creating new document

Trying to create simple Business cards:  some text, an image overlaid with colored text (created in oodraw) copied/pasted.  
After restarting several times, some of the below issues seemed cleared up; but the Synch button disappeared making the Business Card feature useless.

Issues:

1. moving image with arrow keys worked; but Alt+arrow moves underlying frame instead of find-tuning image location -- image was clearly selected.
To see this, place text cursor in another card frame and press Alt+arrow multiple times. The frame is not selected, yet moves.
2. Trying to start fresh, the Business Cards dialog:
   Medium   Private   Business   [Format]   Options
displayed HUGE text over the image:
   V.  from V.Pitch
   Co  from Columns
maybe some other text; I only noticed the source text because the V. and Co were not in card I was designing.
3. Saved and re-0pened document, hoping to get Sync button back -- nope.
4. File>New>Business Cards; (dialog now looks fine):
   Format settings: 3.50", 2.00", 3.50", 2.00", 0.25", 0.25", 2, 5, 7.25", 10.25"
   (the last two are calculated) then click New Document and page layout is wrong...  I see only side-by-side frames in rows 1,3,4 (missing 2 & 5); plus Page Format in right panel shows 3.94" x 3.94"
While repeating the New Document sequence to make sure I'm reporting correctly, in once case the Sync Labels button (SLB) appeared momentarily; otherwise, no show.
Ah ha...  this new, incorrect document window left panel has Frame AND Sections visible; I can make the Sync Labels button appear by moving the mouse over that window. If I now place my working document window (no SLB) covering most of the window with SLB but bad size; I can move the mouse over the barely visible window, SLB appears. Move the mouse over the window without SLB, the SLB disappears, reappears, and disappears within less than one second (a short flash).

Closed LO. Started oowriter fresh. Stilll no SLB...  Try again with New Document; still get bad layout (item 4 above); but now the SLB doesn't appear...  :p

Giving up... will try to create and manually sync in oodraw...

LOL...  trying to get screen shots and noticed SLB on New Document appears on far side of other monitor; but not for the original document I was working on.

Operating System: Mageia 9
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.2
Kernel Version: 5.17.11-server-1.mga9 (64-bit)
Graphics Platform: X11
Processors: 20 × 12th Gen Intel® Core™ i7-12700K
Memory: 62.5 GiB of RAM
Graphics Processor: AMD Radeon RX 6600 XT
Comment 1 Pierre Fortin 2022-06-01 20:06:39 UTC
Created attachment 180530 [details]
New Document layout does not match dialog
Comment 2 Timur 2022-06-03 10:04:23 UTC
This is not easy to follow. 
Please write simple steps for a single bug, preferably with a sample attached.
Comment 3 Pierre Fortin 2022-06-03 11:59:33 UTC
OK... Let's start with this:
oowriter
File->New->Business Cards
I see attachment 180529 [details]
Click: New Document
I see attachment 180530 [details] (highlighted areas are different from requested)
Comment 4 Pierre Fortin 2022-06-03 12:24:33 UTC
Created attachment 180552 [details]
attempt to correct settings

Correcting page size (changed 3.94x3.94 to 8.5x11).  Page size now displaying correctly via unnecessary manual intervention; but card size is definitely not 3.5"x2", and not resizable from here. My settings in the dialog are ignored. Selecting a Label frame, the status bar shows it is 1.84x0.74, not 3.5x2 with no apparent way to resize the 10 frames.
Comment 5 Pierre Fortin 2022-06-03 12:42:46 UTC
Created attachment 180553 [details]
closer look at wrong document size

Since the New Document opens with wrong page size (3.94x3.94), a closer look shows that the business card frames (besides being the wrong size) are not numbered correctly, and/or their positions are the problem.
BTW: I have NEVER used 3.94x3.94 for any document on this system which was purchased just under 3 months ago.
Comment 6 Timur 2022-06-03 13:22:39 UTC
I don't confirm. Maybe because my initial page size was A4 so I didn't need to change Paper size. Is 3.94x3.94 some your default? Obviously that's not enough to fit. 
I also don't reproduce your missing rows. Frame numbering is related to that. 

What I noticed is that 1st open window Medium-Brand doesn't automatically change values in Format but I assume that's for bug 112330.
Comment 7 Pierre Fortin 2022-06-03 18:17:43 UTC
Created attachment 180562 [details]
BusinessCard -- image not synch'ed

Never used that size.  No idea how oowriter decided to use it.
Trying something different (because I see "User")...
Selected:
 - Avery Letter Size
 - 5371 Business Card - White
This provides proper layout form.  

However, when I add an image, I can move it with arrow keys; but when I use Alt+arrow to fine-tune the selected image location; instead of moving the image, it moves the *frame*...  

If I select the frame, the arrows or Alt+arrows do not move the frame... 

Obviously, focus is on the wrong item.  

If I then drag the image, I now can use Alt+arrows to fine-tune its location.

Now that I have the card designed, Synchronize Labels is available (have not reproduced yesterday's situation where the SLButton disappeared.  Clicking SLB, the text is copied to the other frames; but not the image.
Comment 8 Pierre Fortin 2022-06-03 18:29:14 UTC
Argh...  Saved the above document, and tried starting fresh. New Document gives the previously selected Avery form; good.
Then I copied the text and image into the new document. Again, Alt+arrows move the frame.  Now, Alt+arrows moves the selected image *AND* the frame.
Reproducing this issue is unreliable; sometimes works, sometimes not...  ;p
Comment 9 Timur 2022-06-06 13:44:55 UTC Comment hidden (obsolete)
Comment 10 Pierre Fortin 2022-06-07 17:26:32 UTC
Focusing on Alt+arrows:
Note that the wrong object moves (not consistent; but generally happens):  when the image is selected, or nothing selected: Alt+arrow moves the master frame (which probably should *never*[1] move) -- the goal is to line up an image with the frame; not the other way around, which would make the print output partially unusable (esp if using pre-perforated forms).

Just re-opened the last business card file I worked on; selected the image -- Alt+arrows (all directions) moves the frame and contents, so no way to align image to frame in this session. Only the master frame is affected; all other frames are locked in place.

[1] I can't imagine a valid reason for moving the master frame. Moving ALL the frames to line up with a perforated, or pre-printed background, form is a more likely reason to move any frames...
HTH
Comment 11 Timur 2022-06-08 14:43:47 UTC
(In reply to Timur from comment #9)
> I only reproduce this problem: Alt+Arrow move image up and down but not left
> and right. Arrow or Shift+Arrow move it in all directions. Windows only.

I don't reproduce more, so I cannot confirm.
Maybe you can attach a screencast.
Comment 12 Pierre Fortin 2022-06-08 15:30:53 UTC
Got a screencast suggestion?  I've not had much luck finding one that doesn't generate huge files.
So will provide screenshots with comments...
Comment 13 Pierre Fortin 2022-06-08 15:32:19 UTC
Created attachment 180634 [details]
Nothing selected

With nothing selected, Alt+arrows does nothing as expected.
Comment 14 Pierre Fortin 2022-06-08 15:35:45 UTC
Created attachment 180635 [details]
Image selected

Selected image and hit:
Alt+up_arrow 5 times
Alt+left_arrow 5 times
and entire frame moved up and left.
Comment 15 Pierre Fortin 2022-06-08 15:37:56 UTC
Created attachment 180636 [details]
Frame selected

Selected frame. Alt+arrows does nothing.
Comment 16 Pierre Fortin 2022-06-08 15:40:11 UTC
Created attachment 180637 [details]
Selected text

Selected text and hit:
Alt+up_arrow 5 times
Alt+left_arrow 5 times
which moved frame...
Comment 17 Pierre Fortin 2022-06-08 15:43:53 UTC
Created attachment 180638 [details]
Frame 2

Selecting frame 2 or its image, arrows do nothing as expected...  BUT... see next screenshot...
Comment 18 Pierre Fortin 2022-06-08 15:50:14 UTC
Created attachment 180639 [details]
Text in frame 2

Selected text in frame 2. Hit left arrow and "Lastname" was unselected and cursor moves left/right with left/right arrows.  Re-selected "Lastname" and hit:
Alt+up_arrow 5 times
Alt+left_arrow 5 times
and frame moves.  Other than the Master Frame (#1), all other frames are normally locked in position, except for this case.
Comment 19 Pierre Fortin 2022-06-08 15:51:45 UTC
Created attachment 180640 [details]
Business card file used for screenshots

Here's the file I'm working with; hopefully you can reproduce with it...
Comment 20 Timur 2022-06-09 07:54:52 UTC
With attachment 180562 [details], I can only reproduce in Windows: Alt+Arrow move image up and down but not left and right.I found an explanation. 
Alt+Left Arrow inserts Chart, Alt+Right Arrow inserts Image. Those LO keyboard shortcuts don't seem well selected because they are not consistent with Alt+Up and Alt+Down. 
I don't know where Alt+Up and Alt+Down (and Shift+Up and Shift+Down) are defined to move image.

With attachment 180640 [details] I repro as reported (also Windows): Business Cards Alt+Up and Alt+Down moves the frame instead of image, Alt+Left and Alt+Right nothing. 
That's because of image was (probably when grouped itself) grouped with frame, on normal paste this doesn't happen.

I close as NAB. 

About Alt+, that's not worth a bug probably, who uses it can customize LO, simply delete shortcuts Alt+Left for Chart, Alt+Right for Image.