Bug 149554 - CRASH: using empty transpose
Summary: CRASH: using empty transpose
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.5.0 target:7.4.0.0.beta2
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2022-06-13 15:10 UTC by Xisco Faulí
Modified: 2022-06-16 13:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By: Luboš Luňák


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2022-06-13 15:10:31 UTC
Steps to reproduce:
1. Open empty calc document
2. Select A1:C3
3. Copy
4. Paste Special - Transpose

-> Crash

Reproduced in

Version: 7.4.0.0.alpha1+ / LibreOffice Community
Build ID: d4123356c61db269651e950a0a2cc93e6d801c90
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: x11
Locale: es-ES (es_ES.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2022-06-13 15:11:57 UTC
Regression introduced by:

author	Luboš Luňák <l.lunak@collabora.com>	2022-03-30 11:58:04 +0200
committer	Luboš Luňák <l.lunak@collabora.com>	2022-04-28 05:51:53 +0200
commit 9e2d48b9e04f7ea895fb095699c32ed8a44eb129 (patch)
tree e7762a098c6dc066d9dc73888bd3c992cbb13490
parent ee57936475064b409565490022f414220656e12c (diff)
reduce Calc's INITIALCOLCOUNT to 1
 
Bisected with: bibisect-linux64-7.4

Adding Cc: to Luboš Luňák
Comment 2 Commit Notification 2022-06-14 08:58:44 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ef1be22efb3e1625da1683ea98392cc41657b1cd

allocate columns in ScTable::TransposeClip() (tdf#149554)

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Rafael Lima 2022-06-14 14:20:05 UTC
I have just tested using a build that comes after the patch and the problem is still there, but a bit differently:

Steps to reproduce:
1) Select cells A1:C3
2) Ctrl + C
3) Ctrl + Shift + V (Paste special dialog opens)
4) Transpose All (runs ok the first time)
5) Press Ctrl + Shif + V again
5) Transpose All
6) Crash

Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: 66b849eab05bb6b696cced84ca90c17ca1bc31dd
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: CL
Comment 4 Commit Notification 2022-06-14 19:23:12 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/629d2db54bd9f97d2c494b85637a83229275a1a6

tdf#149554: sc_ucalc_copypaste: Add unittest

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2022-06-15 04:26:36 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/650c3477aa4120cafcb9f0e77b341b1ac70de048

allocate columns in ScTable::TransposeClip() (tdf#149554)

It will be available in 7.4.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2022-06-15 05:00:56 UTC
(In reply to Rafael Lima from comment #3)
> I have just tested using a build that comes after the patch and the problem
> is still there, but a bit differently:
> 
> Steps to reproduce:
> 1) Select cells A1:C3
> 2) Ctrl + C
> 3) Ctrl + Shift + V (Paste special dialog opens)
> 4) Transpose All (runs ok the first time)
> 5) Press Ctrl + Shif + V again
> 5) Transpose All
> 6) Crash
> 
> Version: 7.5.0.0.alpha0+ / LibreOffice Community
> Build ID: 66b849eab05bb6b696cced84ca90c17ca1bc31dd
> CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
> Locale: pt-BR (pt_BR.UTF-8); UI: en-US
> Calc: CL

Hi Rafael,
I can't reproduce it in

Version: 7.4.0.0.beta1+ / LibreOffice Community
Build ID: 76698a4a1c8e514962cc54fd9ddc73e39fce7177
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: es-ES (es_ES.UTF-8); UI: en-US
Calc: threaded

Could you please try again with a daily build and a clean profile ?
Comment 7 Rafael Lima 2022-06-16 01:31:34 UTC
(In reply to Xisco Faulí from comment #6)
> Could you please try again with a daily build and a clean profile ?

I tried with today's build and the problem is no longer happening.

System info

Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: cb83063cc0eb4e93bd44bc0cb9b7c4841230cdef
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: threaded
Comment 8 Commit Notification 2022-06-16 08:05:07 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e445eac863ac616fb99c9d6bf5510b965fd15957

allocate column in ScTable::DeleteBeforeCopyFromClip() (tdf#149554)

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2022-06-16 13:16:00 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/b2b8cfe9c8d035be6ba86e5e13f295059c105384

allocate column in ScTable::DeleteBeforeCopyFromClip() (tdf#149554)

It will be available in 7.4.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.