Bug 149844 - LibreOffice hangs on Auto Filter with Filter Criteria then press CTRL + A then try to align Left/Center/Right
Summary: LibreOffice hangs on Auto Filter with Filter Criteria then press CTRL + A the...
Status: RESOLVED DUPLICATE of bug 147842
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2022-07-04 11:27 UTC by bugfree
Modified: 2022-10-19 07:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example spreadsheet to replicate a LibreOffice hang. (11.38 KB, application/vnd.oasis.opendocument.spreadsheet)
2022-07-04 11:27 UTC, bugfree
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugfree 2022-07-04 11:27:05 UTC
Created attachment 181106 [details]
Example spreadsheet to replicate a LibreOffice hang.

1. Open the attached .ODS file.
2. Auto Filter should be enabled on the top row and there should be an active filter on the "Paid" column. 
3. Press CTRL + A to highlight the entire spreadsheet.
4. Press the text alignment buttons Left/Center/Right.
5. "LibreOffice Calc" is not responding.
6. Takes about a minute until it finishes and becomes responsive again depending on which alignment button you press.

This only seems to happen when there are active filters enabled.

Version: 7.3.4.2 / LibreOffice Community
Build ID: 30(Build:2)
CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Ubuntu package version: 1:7.3.4-0ubuntu0.22.04.1
Calc: threaded
Comment 1 Rafael Lima 2022-07-04 12:24:53 UTC
Repro in

Version: 7.3.3.2 / LibreOffice Community
Build ID: 30(Build:2)
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Ubuntu package version: 1:7.3.3~rc2-0ubuntu0.21.10.1~lo1
Calc: threaded

And also repro in

Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: 61f5c991a97de8990badfed6ef840941b5aa8c7f
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: threaded

Following the steps described by the OP LibreOffice hangs when I try to align to the right.
Comment 2 Rafael Lima 2022-07-04 13:42:10 UTC
This problem only happens if a filter criteria is applied. Removing the filter from the "Paid" column does not cause LO to hang.

It seems to be a AutoFilter-related problem.
Comment 3 Aron Budea 2022-07-04 14:36:06 UTC
Already in 3.3.0.

For me the hang happens if I switch to Center, and then to Left / Right.
If I only switch between Left and Right, there's no hang.
Comment 4 Andreas Heinisch 2022-10-19 07:04:03 UTC
Imho a duplicate. It seems to work now.

*** This bug has been marked as a duplicate of bug 147842 ***