Bug 150251 - Commandline: >soffice --help gives wrong Information
Summary: Commandline: >soffice --help gives wrong Information
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
7.0.4.2 release
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.5.0
Keywords:
Depends on:
Blocks:
 
Reported: 2022-08-03 16:37 UTC by Werner Tietz
Modified: 2022-08-04 13:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Werner Tietz 2022-08-03 16:37:58 UTC
Description:
Calling from Commandline ```soffice --help``` tells:   

   {file} {macro:///Library.Module.MacroName}                                  
                       Opens the file and runs specified macros from           
                       the file.  

Thats not correct, to run embedded Macro you need to put a dot in front of last slash, eg.   

> {file} {macro://./Lib…



Steps to Reproduce:
1.on commandline|Terminal|console type:

soffice --help


Actual Results:
   {file} {macro:///Library.Module.MacroName}                                  
                       Opens the file and runs specified macros from           
                       the file.                                       

Expected Results:
   {file} {macro://./Library.Module.MacroName}                                  
                       Opens the file and runs specified macros from           
                       the file.                                       


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.4.2
Build ID: 00(Build:2)
CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Raspbian package version: 1:7.0.4-4+rpi1+deb11u1
Calc: threaded
Comment 1 Werner Tietz 2022-08-03 17:15:00 UTC
Suggested patch for:
https://git.libreoffice.org/core/+/2c9972b8d40dce72cc6f56f1d44db838bd0ece10

-47        "   {file} {macro:///Library.Module.MacroName}\n"
+47        "   {file} {macro://./Library.Module.MacroName}\n"
Comment 2 Julien Nabet 2022-08-03 19:02:13 UTC
Werner: perhaps you'd like to directly submit your patch for review? If yes, this link may help:
https://wiki.documentfoundation.org/Development/GetInvolved

Mike: thought you might be interested in this one.
Comment 3 Werner Tietz 2022-08-04 05:57:24 UTC
@Julien Nabet:
At the moment rather not, to me the effort for a registration on 'gerrit' is a bit disproportionate to write literally a `dot` into a file.
(May be also I would need to `git pull…` the WHOLE Lo-Source to make it happen ??)
Comment 4 Julien Nabet 2022-08-04 06:03:36 UTC
(In reply to Werner Tietz from comment #3)
> @Julien Nabet:
> At the moment rather not, to me the effort for a registration on 'gerrit' is
> a bit disproportionate to write literally a `dot` into a file.
> (May be also I would need to `git pull…` the WHOLE Lo-Source to make it
> happen ??)

I understand but I thought that since you had already retrieved the code, built it and begun to study some parts, perhaps it could have been just a first patch.
Anyway, forget it and let's wait for comments here.
Comment 5 Mike Kaganski 2022-08-04 07:28:49 UTC
https://gerrit.libreoffice.org/c/core/+/137780

(In reply to Werner Tietz from comment #0)

Thank you!

(In reply to Werner Tietz from comment #3)
> (May be also I would need to `git pull…` the WHOLE Lo-Source to make it
> happen ??)

No, you would not need to pull locally to be able to edit in the Wed UI; but nevermind, the change mentioned above would hopefully address the issue in the command line output (and a similar change would be needed in online Help).
Comment 6 Commit Notification 2022-08-04 12:38:03 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a999b8dc83a9ee1749502eb909794cddc6f34f84

tdf#150251: clarify macro URL authority in command line help

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2022-08-04 13:10:47 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/cf46caf4868e0061c9886bad0303b8e7c2ebd7a1

tdf#150251, Help part